CircuPool RJ45+ Cell Connection Error

Monty812

New member
Jul 23, 2021
1
Florida
I recently purchased the RJ45+ package in May 2020 and just installed it in Late June. Since installing it, it has had an error of Cell Connection. I contacted CircuPool directly about this problem and they sent me an adaptor to install that "should" fix the problem. Got it installed and still said the same thing on the display "Cell Connection". I called them a second time to discuss the issue and they decided to ship me a NEW cell as a replacement. Got it last week and still didn't fix the problem. Called them back a third time and they sent a return label for the controller and the replacement cell. This problem occurs when plugging the unit in to Power it up. It shows "Cell Connection" whether the Cell is plugged in or disconnected. Also, The Power light is on but you cannot turn the unit off or scroll through any of the menu options. It just stays on and you have to unplug to Power it down. I received an email yesterday (July 22) and here's what they said. See below for their replay. Here are the things I've checked per installing and trying to troubleshoot.
Switched wiring to 110V
Made sure unit was completely dry per installing
Checked connection pins on the bottom of the control box to make sure they weren't pushed up
Double and triple checked direction of the Flow Switch and Cell
Has anyone had this issue and what did you end up doing to solve?

Email received

Order Notes​

Your equipment passed all tests and all readings were accurate. The equipment is 100% operational and NO parts have been found to need replacement. We could not recreate a cell connection issue.


Thanks Jay
 

Texas Splash

Mod Squad
TFP Expert
LifeTime Supporter
Jun 22, 2014
40,261
Texas, San Antonio/Marion, South-Central Area
Pool Size
17888
Surface
Fiberglass
Chlorine
Salt Water Generator
SWG Type
CircuPool RJ-45 Plus
Welcome to TFP! :wave: Well, that's a puzzle for sure. :scratch: We may ask some duplicate questions as well so bear with us, but at this point you're probably willing to try anything. So let's see:

- How about posting a pic of your control module install and the cell itself so we can see everything.
- Your power source is verified as 110 correct? You installed the 110V jumpers in the module as well right?
- I was going to ask about the cable, but when they shipped you a new cell it had a new cable.
- When you say they sent a label for the controller and cell, does that mean you shipped/exchanged both the cell and module?
 

cowboycasey

Gold Supporter
LifeTime Supporter
TFP Guide
Jul 3, 2013
9,034
Southern OK
Pool Size
15000
Surface
Vinyl
Chlorine
Salt Water Generator
SWG Type
CircuPool SJ-40
This is the first time I have heard of any RJ failing.. no one has ever said they needed to replace a board.. They have a 7 year warranty.. are all those boards over 7 years old?
 

cowboycasey

Gold Supporter
LifeTime Supporter
TFP Guide
Jul 3, 2013
9,034
Southern OK
Pool Size
15000
Surface
Vinyl
Chlorine
Salt Water Generator
SWG Type
CircuPool SJ-40
Found this post..

 

timjwilson

Member
Feb 2, 2016
6
Arizona
Found this post..

And I just posted this over in that thread:

Going to chime in here with my recent experience. My 3-year-old Circupool RJ45+ was working fine until a week ago when stopped working, frozen on "Cell Connection" (just to be clear, when working, it shows "Cell Connection" for a few seconds after power on, but then quickly switches to "RJ series" and then normal operation. When broken, it stops on "Cell Connection" and will not advance).

I called Circupool and they suggested reconnecting everything, checking for dirt and bad pins in the connector, etc. I had already done all that but I did it again and no joy.

So they shipped me the magic module. They charged me ~$40 which I assume is list price pro-rated by the 3 years I've owned it. Would've been nice if the fix were free but $40 isn't bad. UPS chose to send it via the scenic route (Houston to New Jersey to Chicago to Tucson) so it took a few days longer to arrive than it should've. Obviously not Circupool's fault.

Once the part arrived it took me about 5 minutes to install and imagine my surprise when it actually worked!

No, I don't know what's in the magic module and I didn't ask. It is interesting that they have a fix ready for this - kind of looks like a design flaw, probably a marginal voltage threshold somewhere. But hey, it works now, so I'm happy.
 
  • Like
Reactions: cowboycasey

MACJO

New member
Oct 19, 2021
2
TUSTIN, CA
I am having the exact same experience. RJ45+ installed 5/2020 and 17 months later with the "Cell Communication" error. Circupool says it suddenly needs an adapter for $8 and $10 shipping. Waiting to install. Has anyone found the adapter to resolve the issue?
 

MACJO

New member
Oct 19, 2021
2
TUSTIN, CA
I recently purchased the RJ45+ package in May 2020 and just installed it in Late June. Since installing it, it has had an error of Cell Connection. I contacted CircuPool directly about this problem and they sent me an adaptor to install that "should" fix the problem. Got it installed and still said the same thing on the display "Cell Connection". I called them a second time to discuss the issue and they decided to ship me a NEW cell as a replacement. Got it last week and still didn't fix the problem. Called them back a third time and they sent a return label for the controller and the replacement cell. This problem occurs when plugging the unit in to Power it up. It shows "Cell Connection" whether the Cell is plugged in or disconnected. Also, The Power light is on but you cannot turn the unit off or scroll through any of the menu options. It just stays on and you have to unplug to Power it down. I received an email yesterday (July 22) and here's what they said. See below for their replay. Here are the things I've checked per installing and trying to troubleshoot.
Switched wiring to 110V
Made sure unit was completely dry per installing
Checked connection pins on the bottom of the control box to make sure they weren't pushed up
Double and triple checked direction of the Flow Switch and Cell
Has anyone had this issue and what did you end up doing to solve?

Email received

Order Notes​

Your equipment passed all tests and all readings were accurate. The equipment is 100% operational and NO parts have been found to need replacement. We could not recreate a cell connection issue.


Thanks Jay
They probably installed the adapter part for you. Obviously these units have a design flaw to be failing under 2 years.
 

djdonte

Well-known member
Mar 25, 2019
475
Houston, TX
Pool Size
11300
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
CircuPool RJ-30 Plus
I'll go ahead and bump this thread since it is somewhat recent. I have an RJ-30+ that is 23 months old and started with the cell connection error. Must have been broke for a while because its not warm here yet and I had zero FC in my pool.

DSP told me the same, that I needed some adapter for the cell to talk to the control unit. It doesn't really make sense to me. However, the adapter is out of stock, so they shipped me a replacement cell (I paid shipping) until this adapter comes in. They want me to send back the cell when I get the adapter. How did the adapter work out for you guys? I got the temporary cell the next day and it fired right up. I live about 40 miles from DSP.

Regarding the warranty, it looks to be pro rated after the 2nd year, so they would only cover a percentage depending on how old it is. When purchasing, I assumed the pro rated warranty was only for the salt cell, as it is a wear item, but now I'm not so sure. I would hope regular breakdown would not be pro rated.
 

Enjoying this content?

Support TFP with a donation.

Give Support

djdonte

Well-known member
Mar 25, 2019
475
Houston, TX
Pool Size
11300
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
CircuPool RJ-30 Plus
Looks like any part of the system is pro rated after 2 years not just the cell:
First Year - No charge for parts.
Second Year - No charge for parts.
Third Year - Parts supplied at 50% of base price.
Fourth Year - Parts supplied at 50% of base price.
Fifth Year - Parts supplied at 50% of base price.
Sixth Year - Parts supplied at 75% of base price.
Seventh Year - Parts supplied at 75% of base price
 

Bygracealone

New member
Jun 13, 2017
2
South Park, PA
I'll go ahead and bump this thread since it is somewhat recent. I have an RJ-30+ that is 23 months old and started with the cell connection error. Must have been broke for a while because its not warm here yet and I had zero FC in my pool.

DSP told me the same, that I needed some adapter for the cell to talk to the control unit. It doesn't really make sense to me. However, the adapter is out of stock, so they shipped me a replacement cell (I paid shipping) until this adapter comes in. They want me to send back the cell when I get the adapter. How did the adapter work out for you guys? I got the temporary cell the next day and it fired right up. I live about 40 miles from DSP.

Regarding the warranty, it looks to be pro rated after the 2nd year, so they would only cover a percentage depending on how old it is. When purchasing, I assumed the pro rated warranty was only for the salt cell, as it is a wear item, but now I'm not so sure. I would hope regular breakdown would not be pro rated.
I've got the RJ45+ and just got the same cell connection error. Bought the unit in May 2020. Called Circupool customer support and they're sending me the adapter to "fix" the problem. Hoping it works. Will follow-up once I get it and install it.
 

djdonte

Well-known member
Mar 25, 2019
475
Houston, TX
Pool Size
11300
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
CircuPool RJ-30 Plus
I still have DSPs "loaner cell." I pinged them and let them know I still have it and asked them a technical question. They answered my question but did not address the fact that I still have the free cell. So I guess I have two cells lol?
 
  • Like
Reactions: Bygracealone

Hootz

Bronze Supporter
Feb 5, 2018
282
Rogers, AR
I just had the same trouble with an RJ60+......display reads "cell connection" and couldn't control power or access any menu items. I called Circupool support and the tech asked if I was sure the cell connection was good at the controller. When I told him the cell was connected and the terminals were clean he said I needed the pcb adapter. I got the adapter and it so far it has fixed the issue. I left the timer on for the controller while waiting for the part and noticed that the swg worked for two days and the other two showed the error. If you don't install the adapter don't be fooled if it starts working because it will most likely fail once this condition occurs. As far as the warranty I was two days short of two years so they did not charge for the part or shipping.
 

djdonte

Well-known member
Mar 25, 2019
475
Houston, TX
Pool Size
11300
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
CircuPool RJ-30 Plus
I just had the same trouble with an RJ60+......display reads "cell connection" and couldn't control power or access any menu items. I called Circupool support and the tech asked if I was sure the cell connection was good at the controller. When I told him the cell was connected and the terminals were clean he said I needed the pcb adapter. I got the adapter and it so far it has fixed the issue. I left the timer on for the controller while waiting for the part and noticed that the swg worked for two days and the other two showed the error. If you don't install the adapter don't be fooled if it starts working because it will most likely fail once this condition occurs. As far as the warranty I was two days short of two years so they did not charge for the part or shipping.
That’s weird I was within two years as well and they made me pay 13 bucks to ship the cell.
 

wprileyjr3

Well-known member
Jun 13, 2018
61
Clinton TN
My RJ45+ gave the cell connection error with keypad lockup error over the weekend. Just got off the phone with DSP. Asked if any pins are bent. When I said no he stated they would send the pcb adapter. I have had the unit just over 2 years but he said the adapter is cover 100% and shipping is also covered. I already have email from them showing order placed and no charge said I should have it in 3 days.
 

kipmeyer

New member
Jun 11, 2022
1
08005
I recently purchased the RJ45+ package in May 2020 and just installed it in Late June. Since installing it, it has had an error of Cell Connection. I contacted CircuPool directly about this problem and they sent me an adaptor to install that "should" fix the problem. Got it installed and still said the same thing on the display "Cell Connection". I called them a second time to discuss the issue and they decided to ship me a NEW cell as a replacement. Got it last week and still didn't fix the problem. Called them back a third time and they sent a return label for the controller and the replacement cell. This problem occurs when plugging the unit in to Power it up. It shows "Cell Connection" whether the Cell is plugged in or disconnected. Also, The Power light is on but you cannot turn the unit off or scroll through any of the menu options. It just stays on and you have to unplug to Power it down. I received an email yesterday (July 22) and here's what they said. See below for their replay. Here are the things I've checked per installing and trying to troubleshoot.
Switched wiring to 110V
Made sure unit was completely dry per installing
Checked connection pins on the bottom of the control box to make sure they weren't pushed up
Double and triple checked direction of the Flow Switch and Cell
Has anyone had this issue and what did you end up doing to solve?

Email received

Order Notes​

Your equipment passed all tests and all readings were accurate. The equipment is 100% operational and NO parts have been found to need replacement. We could not recreate a cell connection issue.


Thanks Jay
What was the final result?
I just installed my brand new RJ-45 and got "Cell Connection" error on screen with no ability to use any other buttons.
Everything is installed perfectly fron changing jumpers to 110v, bonding wire, plumbing, location of module. Cell connection looks tight and correct, but no go.
 

Hootz

Bronze Supporter
Feb 5, 2018
282
Rogers, AR
What was the final result?
I just installed my brand new RJ-45 and got "Cell Connection" error on screen with no ability to use any other buttons.
Everything is installed perfectly fron changing jumpers to 110v, bonding wire, plumbing, location of module. Cell connection looks tight and correct, but no go.
The adapter seems to solving this issue. I had the same symptoms on a 2 year old controller and now it works fine after installing the adapter.
 

Undrwtr1

LifeTime Supporter
May 16, 2011
45
Add me to the list. Installed RJ45+ back in May and it is made life so much easier and was working flawlessly. Then today, when checking my levels, FC was way lower than normal for the past couple of months. "Cell connection" error - can't get past that. Checked all connections, all clean, no change. I just emailed them asking abpout the PCB part. I hate that I had to add liquid today!!!! Hopefully I will get the part soon.
 

Enjoying this content?

Support TFP with a donation.

Give Support