Cannot Upgrade Omnilogic Firmware

jdenmark

New member
Dec 24, 2020
1
Massachusetts
Hi, I am hoping that someone may have a solution to this problem. I have a wired connection, model HLBASE, and my firmware needs updating. I have never updated the firmware, so I am a few versions behind. I have followed all steps on this forum and on the Hayward website. My problem is that the Omnilogic will not recognize my USB drive, and subsequently, the firmware files I have downloaded onto it. When I go into service mode and try to update the firmware, the USB drive that I have properly plugged in, is just not recognized. I have tried the following based on a previous thread:

-downloaded earlier firmware versions
-used a smaller size USB drive
-used a different USB drive
-used Chrome browser for download
-deleted .txt file extension

Thank you for any thoughts and guidance!
 

ajw22

Gold Supporter
TFP Guide
Jul 21, 2013
28,078
Northern NJ
Pool Size
35000
Surface
Plaster
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-60
Welcome to TFP.

It sounds like you tried all the usual suggestions. See if there is any new information for you at Hayward OmniLogic - Further Reading

How old is your pool and OmniLogic panel?

Have you contacted Hayward or a local Hayward dealer and made a warranty claim?
 
Last edited:
Thread Status
Hello , There was no answer in this thread for more than 60 days.
It can take a long time to get an up-to-date response or contact with relevant users.