Canister filter/paper cartridge blowing dirty water back into pool

JimDangle

Member
May 28, 2017
7
Charleston/SC
I had an algae bloom in our 15k gal above ground pool after being taking a short trip. I am near the end of the SLAM right now (CYA: 30, FC: 12, CC: 0, pH: 7.4, water is crystal clear until I vacuum--see below) and am vacuuming up the dead algae from the bottom of the pool.

But I noticed a few days ago that the return was blowing dirty water back into the pool during vacuuming. I pulled the cartridge from the canister to check the pleats for tears or holes and didn't find any. The cartridge is almost two seasons old (I clean it regularly and the pressure on the old cartridge was normal), so I went to the pool store to buy a replacement. Just got back and vacuumed the pool again, and again, with the new filter, dirty water (less, but still some) returned into the pool once I started vacuuming the algae.

I looked down into the canister, and I don't see any rings or valves that could go bad and leak. There is just the hole in the side of the canister that sends in water from the pump and the fitting in the bottom that the cartridge sits on to send clean water into the pool. I looked at the cap and the same thing is there--Just a fitting that sticks down in the top of the filter to separate the clean water from the dirty water.

I don't know how old the canister itself is. It came with the house, so at least six years old. Do those fitting wear out letting unfiltered water seep into the return line? Any advice?
 

Texas Splash

Mod Squad
TFP Expert
LifeTime Supporter
I know you posted this a week ago, but it sounded like your cartridge filter was still overwhelmed with either live or dead organic material. Are you still in the SLAM Process? It might help if you updated your signature with all of your pool and equipment info so we would know what type of filter (and other items) you have. Thanks for posting.
 

JimDangle

Member
May 28, 2017
7
Charleston/SC
Thanks for taking a look.
I know you posted this a week ago, but it sounded like your cartridge filter was still overwhelmed with either live or dead organic material.
Could be, but I have my doubts (see below). I've opened up the pool every year for five years to a swamp and have vacuumed it many times during SLAM without the filter spewing dirt back into the pool. Something has changed/broken/whatever. I'm trying to narrow it down to what that is. And I have (possibly?) narrowed it down to "not the cartridge" and that's it.

Are you still in the SLAM Process?
No.

It might help if you updated your signature with all of your pool and equipment info so we would know what type of filter (and other items) you have. Thanks for posting.
I'll figure out how to do that when I have some free time. But if it helps, it looks like the canister filter is a Black Diamond PRC90D8 (the only label on the canister is very faded and it came with the pool which came with the house).

Also, how, physically speaking, does the cartridge get "overwhelmed?" The dirty water has to get on the other side of the filter media somehow. There appear to be only three ways to do that: through the fitting that holds the top of the cartridge, through the fitting that holds the bottom of the cartridge, and through the actual cartridge itself. If the filter was so dirty (and it isn't; I keep it clean) that dirty water was being forced through where the fittings hold the cartridge, I'd think I'd see an dramatic increase in pressure . . . which I haven't.
 
Last edited: