Bubbles in the skimmer basket and return

mjninc

New member
May 2, 2020
4
30060
Hello, I am working on a 24' round 52" pool with a 1.5hp, 2 speed motor and a 26" sand filter, with 1.5 inch flex pipes, one 12 foot long to the filter ans another 12 fool o e to the return.

When I run on low, no bubbles in the basket attached to the pump (not the skimmer basket) or the return.

When I run on high, it seems like it sucks in bubbles through the skimmer basket, I can see them and a bunch of super small ones come out of the return.

I've put in a new o-ring with lube and tightened it as much as I can and on high the bubbles still come in.

Is there anything else I can try?

Pump is a waterway SD 15-2n11m

Thanks for the help.
 
Last edited:

pHmadness

In The Industry
May 2, 2020
5
Middle TN
Hello, I am working on a 24' round 52" pool with a 1.5hp, 2 speed motor and a 26" sand filter, with 1.5 inch flex pipes, one 12 foot long to the filter ans another 12 fool o e to the return.

When I run on low, no bubbles in the skimmer basket or the return.

When I run on high, it seems like it sucks in bubbles through the skimmer basket, I can see them and a bunch of super small ones come out of the return.

I've put in a new o-ring with lube and tightened it as much as I can and on high the bubbles still come in.

Is there anything else I can try?

Pump is a waterway SD 15-2n11m

Thanks for the help.
My first thought is that your water level is low. If your skimmer isn't stay full of water on high, you will pull air into the system and push it out through the returns
 

zea3

Mod Squad
TFP Expert
LifeTime Supporter
Jul 10, 2009
12,448
Houston, Texas
Hi, welcome to TFP! It sounds like a water level issue. The water should be at least 1/2 way up the skimmer opening.
 

mjninc

New member
May 2, 2020
4
30060
Sorry all, I meant to say the bubbles are coming in the basket attached to the pump, not the skimmer. The water level in the skimmer doesn't get low enough to suck in air when it's turned on high.
 

zea3

Mod Squad
TFP Expert
LifeTime Supporter
Jul 10, 2009
12,448
Houston, Texas
When the pump is off the water level should be between 1/2 and 3/4 the way up the skimmer. Do you see a vortex in the skimmer basket when the pump is running on high? If those are good the next thing to check is the pump pot lid. Make sure the o-ring is in good shape, coat it with silicone lube and that it closes fully. Make sure the drain plug on the pump pot is snug, and if you are still getting air in the pump on high speed get a hose and check all the pipe joints for air leaks.
 

mjninc

New member
May 2, 2020
4
30060
Thank you all for responding. I filled it up to the proper level, still the same issue. I need to try the lube and water hose idea. Thank you!