Breakers keep tripping, every time i turn on my hot tub

Slpoolowner

Active member
Jul 5, 2018
38
Sugar Land/Texas
A bit of a new phenomenon for my pool, but was trying to turn on my pools heater for the hot tub/spa, but it seems right before the heater fires, the circuit breaker trips. Its quite odd, and not sure what to do, or who to call to inspect it? Any thoughts or help? All my other components work fine, the other pumps, valves, pool lights, etc. Its only when i turn on the hot tub and the heater is about to fire.
 

Attachments

ajw22

Gold Supporter
TFP Guide
Jul 21, 2013
16,162
Northern NJ
What model heater and pump do you have?

Your top breaker says "Pool Pump"

Your third breaker says "Waterfall Pump"

The middle breaker has opened and the writing is illegible. Are you sure you know what is connected to it?
 

RDspaguy

In The Industry
Mar 21, 2020
590
Cabool, Mo
I never checked. But regardless still cannot turn on my hot tub
It is an important detail, and tells us if it is your heater or something else.
Has the heater been working up 'til now, or has it been recently started?
Can you post a pic or 2 of the equipment. Pumps, heater, salt cell, etc...
 

Slpoolowner

Active member
Jul 5, 2018
38
Sugar Land/Texas
Hi All
My heater has been working fine; i have a Pentair MasterTemp 400.

So, i went outside yesterday and decided to check if i was able to get it to fire; and lo and behold, system works fine without tripping. Makes no sense to me.
 

RDspaguy

In The Industry
Mar 21, 2020
590
Cabool, Mo
Something got wet, now it has dried. If it gets wet again it will start tripping again. If the pump has been off for a few days, it is probably a leak and will be tripping again soon. The pump being off will cause the leak to stop which allows stuff to dry, but once the pump is back on the leak starts up again and gets it wet.