Brand new sand filter leaking.

Surplus43

Member
Jun 24, 2019
5
Philadelphia
Ok so i upgraded to an intex 2800 sand filter. Just installed it. Filled the pool. And its leaking at the leaf basket orings on the pump motor inlet. I though maybe it wasnt tight enough (dont over tighten the nut, the threads strip out). Not the issue. Im under the impression its the orings not being large enough to create a seal. I lubed it with a silicone grease. But still leaked. Is there anyway to fix this? Maybe with a liquid gasket like used in automotive? Maybe even doubling up on the orings?
 

Texas Splash

Mod Squad
TFP Expert
LifeTime Supporter
Welcome to TFP! :wave: No other way though. Assuming the O-ring is factory-original and not damaged, it should only require a smooth, consistant amount of pool silicone lube to help it stay in-place and seal and potential air leaks. If that's not working, you may want to contact Intex or the seller to see if you cna get a new O-ring.
 
  • Like
Reactions: Surplus43

Surplus43

Member
Jun 24, 2019
5
Philadelphia
I fixed it with electrical tape. First removed the o rings. Then wraped a length of tape tightly around the oring slots to build up material. Replaced the orings and test fit a few times, removing a length of tape at a time untill i was able to slide the basket onto the pump. Its nice and tight now. No leaks for now. Relubed with silicone grease and called it a night. I ordered a new basket and new nut (stripped a thread). Just incase i need to get more creative.