Automatic Cleaner, not cleaning?

Molson

LifeTime Supporter
Apr 15, 2008
479
Midland, Ontario
I have a Barracuda Classic that came with the pool. It has a pressure regulator attachment that is supposed to go on between the hose and the skimmer inlet. With it connected in any setting, the cleaner wil not work. My local pool store advised it is fine to hook directly to the skimmer.

So I did, it seems to be working as designed, there is a pulse in the line and the cleaner meanders around the pool. It will clean what it runs right over.

My chief conplaint is, even if in the pool for 3-4 hours, I can barely tell its done anything. The ouside edge is nice and clean, and a few paths on the bottom. It seems to not be random and get caught in a pattern.

I am using the barracuda sectional hose. The weight it where it should be, 1.5 meters back from the unit.

Any ideers?
 

duraleigh

Admin
Mod Squad
TFP Expert
Platinum Supporter
LifeTime Supporter
In The Industry
Apr 1, 2007
34,518
Sebring, Florida
That's a pretty big pool for a suction-side cleaner. They tend to be pretty slow and work a little better in smaller pools. I fought and fought with my suction side in my large pool for years and finally bit the bullet for a big robotic cleaner........night and day difference.

That said, you might go online for adjustment directions or call tech support.
 

Molson

LifeTime Supporter
Apr 15, 2008
479
Midland, Ontario
Thanks Dave, that is my next step. I was (still am) hoping its something simple as I really don't want to spend the money on a new cleaner right now. As it stands, I'm not going to bother with it as I can get the whole pool manually vacuumed in about 1 beers time.
 
Thread Status
Hello , This is an inactive thread. Any new postings here are unlikely to be seen or responded to by other members. You will get much more visibility by Starting A New Thread