Automatic Cleaner hose getting tangled after many years

kcbaltz

Active member
May 12, 2008
40
Sacramento, CA
I have an automatic cleaner* and it has recently been having trouble with the hose getting tangled/wrapped around the cleaner. It came with the house which we've had for 6 years and has worked well most of that time, so I don't think it's an issue of hose length. It seems to me that the floats aren't floating as much as the should because the ones in the middle seem content to stay submerged a few feet down even if there's slack. Also, I'm not sure the swivels swiveling very well. They feel like they have grit in them. Would it make sense to replace the hose? Is there a way to lubricate/clean the swivels?


* I think it's a Letro Legend - it works with a booster pump and looks kind like this: http://www.bestbuypoolsupply.com/legend.html with different colors (it might be Leslie's branded).
 

JohnT

Admin
Mod Squad
TFP Expert
Apr 4, 2007
9,614
SW Indiana
I would probably consider it. The hose can get a bend to it, and if the swivels are rough, that would make it worse. Price a new cleaner first, because they do wear out.
 

HarryH3

Well-known member
Apr 22, 2008
326
Central Texas
My Polaris 280 started tangling the hose a lot last summer. It turned out that a few of the plastic gear teeth inside one of the drive wheels were broken. This was causing one side to drive further than the other, forcing the Polaris to run in circles instead of a random pattern.

Replacing the drive wheel solved the problem. :)
 

kcbaltz

Active member
May 12, 2008
40
Sacramento, CA
muss08 said:
I'd look to make sure the floats are correctly seperated first. If this doesnt help try replacing the floats and swivels.
What do you mean by the floats being separated? They are evenly spaced along the hose. However, they don't terribly buoyant, so I've considered replacing them. Also, there's a large box on the hose near the cleaner itself. I'm not sure what it's supposed to do, so I don't know if it's working or not.

The tires are worn bald. Is that a big deal as long as it's still sweeping the sides? I did find one of them off the sweeper once, but it hasn't come off again since I put it back on.