Anyone with ScreenLogic want to do me a favor???

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
23,470
Bedford, TX
I have the following page in ScreenLogic..




It shows the local weather across the bottom.. For some reason, it no longer updates.. I tried to update the set up page below, but can't get it to find the local airport.


It won't let me enter anything..

I am just looking to see if it is just me, or if something has changed for everyone??

On the set up page does your system allow you to enter or pick a State? Mine won't anymore.

Thanks,

Jim R.
 

RMcGirr83

Gold Supporter
Nov 19, 2018
970
Tuscola, TX
Jim,

Not sure if you know this or not but the NOAA has an XML feed. Maybe try typing that in directly into the app? Looks like it uses an xml for the data. sorry, don't have screenlogic.

Here's the link

Put in your state and then select the local airport, click on the xml link and try inputting that into the app directly.

For Texas it would be one of these


Here's the feed for Abilene


Other than that you sure the app has internet connection?
 

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
23,470
Bedford, TX
Rich,

Thanks for the links, it gave me a better idea how the weather .xml inputs works.

The system can see the internet as I can change things via my cell (not WiFi) but... It does appear that it is not talking to the weather website, as things are just stuck at the last reading.

In theory, you can select your State, and then your airport location, but none of that works. It is all blank. I guess my next option is to reset the Protocol adapter, but I think I'll wait to see if anyone else is having the same issue.

Thanks,

Jim R.
 

RMcGirr83

Gold Supporter
Nov 19, 2018
970
Tuscola, TX
Something I just noticed, in your screenlogic pic it states
Code:
http://weather.gov
, the link I provided states
Code:
https://w1.weather.gov
. Websites change all the time. Maybe if you change the beginning of that link in the weather params of the screenlogic general settings everything will sync up again?

Just a thought.
 

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
23,470
Bedford, TX
83,

I tried both the old http and the new https://W1. and it made no difference..

I did not try http://W1.. ??

The real problem for me is that it used to allow you to enter your State and then it would find the Internet address.. Now it won't even let me enter a State.

Your link let me manually set up the address, but neither the old way or the new way worked for me. ☹

Thanks,

Jim R.
 

jebbydawg

New member
May 24, 2021
1
Chesterfield, MO
I have the following page in ScreenLogic..




It shows the local weather across the bottom.. For some reason, it no longer updates.. I tried to update the set up page below, but can't get it to find the local airport.


It won't let me enter anything..

I am just looking to see if it is just me, or if something has changed for everyone??

On the set up page does your system allow you to enter or pick a State? Mine won't anymore.

Thanks,

Jim R.
Hi Jim - did you ever get a resolution to this? I'm having the same problem starting this season. Thanks!

Jeff D.
 

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
23,470
Bedford, TX
Jeff,

I sent an e-mail to Pentair and they responded.. The Tech said they had the same issue and he turned in some kind of problem notice up the chain of command..

This was a couple of weeks ago.. Yesterday, I looked and it showed the right days and local weather forecasts.. I was delighted... until today.. Now it is stuck on Sunday's forecast..

I have not heard anything back from Pentair about any kind of timeline for repair..

I went into ScreenLogic Config and it still will not find the local airport.

Thanks,

Jim R.
 

Enjoying this content?

Support TFP with a donation.

Give Support

dssmith99

New member
Jun 3, 2018
1
San Ramon
Jim,

Not sure if you know this or not but the NOAA has an XML feed. Maybe try typing that in directly into the app? Looks like it uses an xml for the data. sorry, don't have screenlogic.

Here's the link

Put in your state and then select the local airport, click on the xml link and try inputting that into the app directly.

For Texas it would be one of these


Here's the feed for Abilene


Other than that you sure the app has internet connection?
I used the .gov website you mentioned, found my local airport, copied the URL and entered it into the "params" field. I changed my zip to match the airport. THEN I clicked "Next" through all setup pages, then "Back" to page 1, then "Finish" This worked.
 

mknauss

Mod Squad
TFP Expert
Bronze Supporter
May 3, 2014
44,826
Laughlin, NV
Pool Size
6000
Surface
Fiberglass
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-40
I used the .gov website you mentioned, found my local airport, copied the URL and entered it into the "params" field. I changed my zip to match the airport. THEN I clicked "Next" through all setup pages, then "Back" to page 1, then "Finish" This worked.
Just set mine up that way and it works! It had been stuck on the same data for weeks.

Thank you!
 

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
23,470
Bedford, TX
@RMcGirr83

I tried this again today and it worked... the App still will not find the airport, but entering the address manually worked. The problem is that I have done this before.. It would work for a few days and then lock up..

We will see what happens this time..

Thanks for all the help..


@dssmith99

Thanks for the post.. It made me look at the thread again and today it worked..

Thanks again,

Jim R.
 

aaron_w_o

Bronze Supporter
Apr 15, 2018
148
ottawa, ontario, canada
Pool Size
40000
Surface
Vinyl
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-20
I didnt even know about this feature.
I am in Canada.
I just tried the setup, but it doesnt find any airports and errors out. I had to force kill screenlogic on my laptop.
Now when I try to connect to my system, I get this:
1623951053491.png
 

aaron_w_o

Bronze Supporter
Apr 15, 2018
148
ottawa, ontario, canada
Pool Size
40000
Surface
Vinyl
Chlorine
Salt Water Generator
SWG Type
Pentair Intellichlor IC-20
false alarm above... you will note the system name was just malformed.
so back to Jim's question...here's what I see now that I set this up. you can see even though my system is in celsius, the weather is coming in F.
I have no idea what weather source it is using...
1623953408092.png
the lat long seems wrong too. I will try to adjust for my address. I wish I knew how to use this weather params thing!
1623953518091.png
 

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
23,470
Bedford, TX
Aaron,

I think that you are just seeing junk that is left over..

If you look at post #2 it shows the NOAA weather site.. You can find the "weather pararms for your airport there. You can copy the link and past it into ScreenLogic. Sometimes that will work. Has not worked for me lately..

Thanks,

Jim R.
 

Enjoying this content?

Support TFP with a donation.

Give Support