algea in my air filter pump?

AussieOi

Member
Feb 24, 2017
23
Australia
Hi I noticed this today in my 2 blower air pumps for my spa.

Spa water & Spa water pump is clear and doesnt look like this

How do I get rid of this green stuff?? It wasnt there a few days ago...
IMG_7335.jpg
 

Patrick_B

TFP Expert
LifeTime Supporter
Jun 7, 2011
14,999
Midland TX
You have to expose it to Free Chorine.

If these pumps don't see freshly Chlorinated water often enough, you'll have this result. If these were mine, and I wasn't using them I would remove the baskets, and soak them in bleach water, replace them, and keep these pumps covered with something, and run them more often. I would only isolate this area for treatment if I was certain this was due to lack of pump use.

If you are running them with any frequency at all, you should follow a SLAM procedure on your pool and make sure you are keeping proper levels of Free Chlorine in it at all times. It is quite likely that you have Algae ready to bloom elsewhere in the pool. Algae does not grow where there is adequate Free Chlorine, so I would make certain this base was covered.

Do you have a proper test kit, and have you had a chance to study Pool School here? Understanding the ABCs, and getting a good handle on the other areas is esssential, and there is always someone here to help with questions if they arise.
 

AussieOi

Member
Feb 24, 2017
23
Australia
How long would u suggest i bleach them for, sitting in bleach water now.
Just a few hrs, a day. I guess I then just hose them off....
Cheers
 

Patrick_B

TFP Expert
LifeTime Supporter
Jun 7, 2011
14,999
Midland TX
Until it's gone mate, and yep wash of the dead stuff then pop them back in. Make sure on the other stuff I mentioned with the FC maintenance overall.
 

Other Threads of Interest