Adventures in Searching

mguzzy

Gold Supporter
Jul 8, 2015
2,229
OV, CA
Hello Good Forum Admins and Modulators
So I am having a heck of a time working with the forum search feature. It doesn't seem to like me. I have problems finding keywords in any consistent fashion. For example searching for keywords by member name. Just the other day I was trying to find OTPirates last posts about the "stirrer". I seemed to get everything but that. And I was getting posts that were not by the 'Pirate, to boot. Also I don't know if its possible to search PM's. .. So this morning I was looking for he word "Banter" below is the result by just typing the word in the search field and hitting enter.. this invokes the Google engine to search the site if I understand it correctly. And this is what I get:
banter-no results.PNG

But if I go Advanced to use the old search method I get lots of hits.:
banter-results.PNG

So WAZ UP, With that? I know there were some issues with search function in the switch over to the new update a few months back. I have come to distrust the Google search feature and I am often left to sort through reams of old posts to find what I am looking for. So, just wondering if the Goo-Roos have any insight into the inner workings of these unruly electrons.
thx
 

RMcGirr83

Gold Supporter
Nov 19, 2018
900
Tuscola, TX
Also I don't know if its possible to search PM's
Doesn't seem to be searchable by word, but by started by, etc. On the top right just above the PM list is a "Filter" button, click it. ;)

BTW, most forum software isn't setup to search on PMs because they're "private" and it would be a bit cumbersome for a database table or two to be able to sort for those that only relate to you, or me, or whomever. Capiche?!
vBulletin may be the sole outlier to that statement but it's got more "fluff" in it than any other forum software out there. So much so that servers have crashed because of the load placed on them by it.

@Texas Splash owes me a scorpion.
 
  • Haha
Reactions: Texas Splash

mguzzy

Gold Supporter
Jul 8, 2015
2,229
OV, CA
So I am misunderstanding the "By Member" field.. that will only pull up matches for threads that were "started by that member" not individual posts by a particular member? (that using the pull down, not the Advanced section, but I don't get any better resulting in the Advanced section"

I will experiment with the filter in the PM and see if it does what I expect. -thx

Everyone should have their own Scorpion I always say. I got stung by one in South America.... I hunted that bad puppy down and caught it.. its proudly displayed on my shelf in a bottle of formaldehyde.
 
  • Haha
Reactions: Texas Splash

RMcGirr83

Gold Supporter
Nov 19, 2018
900
Tuscola, TX
LOL
You just freaked my wife out. That'll teach her from reading over my shoulder.

mguzzy, pretty sure that was brought up in the past, or something like it. As the search uses Google, not sure how google would know who typed what.

FWIW, I think the search should be changed from Google to local anyway as what is returned will probably be more granular. That's my .01 (worth half as much) on that.
 
  • Haha
Reactions: Texas Splash

mguzzy

Gold Supporter
Jul 8, 2015
2,229
OV, CA
Yeah... I get better results using the built in search instead of the Google search. I guess it was considered an upgrade to make the Google search the default, but from my perspective the search is not really better. Not sure why. Perhaps the way it crawls the forum/wiki/article databases or something.
 

Texas Splash

Mod Squad
TFP Expert
LifeTime Supporter
I had a very large scorpion from Saudi Arabia when I was deployed, but it's long gone. You could hear them walking across hard surfaces. Camel Spiders as big as your hand. A couple weeks ago, I had a scorpion on my work shirt near my collar. It was curled-up and I though ti was a moth. It was right next to my chin so I blew on it and it just fell to the ground. That's when I filled my shorts. :poop::poop:
 

Leebo

Admin
TFP Expert
LifeTime Supporter
Jul 21, 2011
9,945
Eastern Ohio
I can't remember the exact date however last year sometime after we completed our migration to the current software we sent out a survey to all active users to ask them some questions on a few items. We broke this survey down into active members (over 5 posts I believe it was) and new users (under 5 posts). One of the questions we asked was point blank and to the point "How pleased are you with the search feature." We scored the lowest on that one question compared to every other question we asked.

This lead us to start peaking at the results on some searches. We started just randomly looking for info using the old search and struggled to find it BUT as soon as we used Google the quality improved. This trend repeated itself over and over, so awhile ago as you remember we altered the software somewhat to make Google search the default search on the forum.

That said, one thing the Google search DOESN'T take into consideration is the info such as poster name and so forth, even though I'll admit the UI right now leads the end user into believing it is. Because of this fact we've left the old search as an option for users. @mguzzy before you type a search go ahead and directly open the "Advanced" option THEN preform the search you were looking for. I greatly suspect the filters will work then.