Adding JVA to water feature

FTC3

Well-known member
Jul 7, 2012
54
Las Vegas
Hello, I recently upgraded my controller to the iAqualink system. Easy upgrade and everything works right out of the gate with the exception of one JVA valve. I’m having trouble setting up one of my water features.

Aux 1 - activates secondary pump and sheer descent. I need to activate a JVA valve to turn on/off my deckjets. The deck jets are physically plumbed after the sheer descent. Meaning the sheer descent is always on with the activation of the secondary pump but I can valve on/off the deck jets.

How do I wire the JVA? I only see 4 JVA ports. Intake, Return, Cleaner, Solar. Intake and Return are used and working properly. I still have 3 open Aux functions.

Many thanks!
 

Dodger

Silver Supporter
Sep 17, 2017
628
Silicon Valley, CA
Try this:

Plug it into either the 3rd or 4th JVA slot. The Cleaner and Solar are pre-named by the factory, but not required to use for those purposes.

Then go into System Setup and Assign JVAs to assign it to an open Aux#.

Then, still in System Setup, go to Label Aux and give it a name that makes sense.
 
  • Like
Reactions: FTC3 and PoolGate

FTC3

Well-known member
Jul 7, 2012
54
Las Vegas
Thanks Dodger. I tried that but no luck.

I assigned the cleaner port to Aux 6 in the JVA menu. I went into the Aux menu and renamed it to “deck jets.”

Just to be clear, I don’t have anything plugged physically into the Aux 6 port? The JVA is plugged into the cleaner port.
 
Last edited:

FTC3

Well-known member
Jul 7, 2012
54
Las Vegas
PoolGate, thanks for the reply.

What would your suggestion be for the proper way to physically wire and program the valve for my deckjets?
 

FTC3

Well-known member
Jul 7, 2012
54
Las Vegas
The handle isn’t on it but I don’t believe so. I will double check to be sure. This JVA is supposed to be full open or close.