Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: leak around clamp band

  1. Back To Top    #1
    rogerbrks's Avatar
    Join Date
    Apr 2007
    Location
    Round Rock, TX
    Posts
    171

    leak around clamp band

    My Polaris Halcyon booster pump has been very loud lately. Neighbors walk by the house and get so concern that they tell me my pump is running dry. I went to look at it and decided to start opening it and realize I didn't have a manual for it now it leaks around the clamp band. Is there a way to re-seal it? If so, what do I use? How is the best way to make the clamp tight enough to stop leaking?

    Thanks for all input.
    21,200 gal IG gunite, CL 580 sqft Cartridge filter, aqua pure salt system, polaris 480-blue&white, Jandy PDA Remote, (4) Jandy Deck Jets

  2. Back To Top    #2
    spishex's Avatar
    Join Date
    Oct 2008
    Location
    Hillsborough, NC
    Posts
    1,375

    Re: leak around clamp band

    The squealing may be the result of a leaky pump seal. Are you sure the water you're seeing isn't just dripping down to the clamp from behind?

    You can lubricate the housing o-ring with some o-ring friendly silicone or teflon lubricant. If you notice your hands getting black in the process, or cracks in the o-ring, go ahead and replace it. In a pinch you could use a silicone sealant to force the issue.

    But take a close look at that pump seal.

  3. Back To Top    #3
    rogerbrks's Avatar
    Join Date
    Apr 2007
    Location
    Round Rock, TX
    Posts
    171

    Re: leak around clamp band

    Thanks for the reply. I applied some silicon and the leak stopped. I'll have someone come out and see why it's so loud.
    21,200 gal IG gunite, CL 580 sqft Cartridge filter, aqua pure salt system, polaris 480-blue&white, Jandy PDA Remote, (4) Jandy Deck Jets

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •