Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 6 of 6

Thread: Newly installed Liquidator won't fill with water?!?

  1. Back To Top    #1

    Join Date
    Oct 2007
    Location
    Central Texas
    Posts
    104

    Newly installed Liquidator won't fill with water?!?

    I installed the Liquidator along with all of Rabbit's modifications. The larger tubes, check valves, etc. The suction side is plugged into the drain plug under the basket of an Intelliflo 4x160. The pressure side is installed into a barb located after the filter and filter bypass valve.

    With the pump at speed 4 the LQ fills up in either bypass or filter mode. At speed 3 it will not fill up in filter mode (no water is entering the LQ). At speed 3 with the filter bypass engaged the LQ will fill. At speed 2 the LQ will not fill in either mode. Its like I can't get any pressure on the 3/8 ID tubing.

    The inlet float is in the open position; it is not stuck closed. The check valve can't be backwards or I would never get any flow. The tubing is 10 feet long. The outlet float is closed because the water level is too low. If I lift it the water flows out quickly.

    I don't have a pressure gauge after the filter but I do have a flow meter. I am getting 105 gpm at speed 3 in bypass mode and 65 gpm in filter mode with a filter pressure of 10psi.

    I can try removing the check valve but this valve doesn't seem optional based on the LQ articles I have read. I will also try getting replacement clear tubing to verify that a tubing obstruction is not the problem but this seems unlikely. Has anyone encountered such a problem?
    Light grey plaster, stone coping, 38K gallon Roman shaped pool with a shallow end beach, table and bar stools, deep end bench and waterfall (Intelliflo 4X160). Taylor K-2006, Pentair 320 chlorinator, Intelliflow VF, Quad DE 100. 4 ColorLogics, 3 skimmers, 14 wall returns, 13 floor returns, TurboTwister slide, autofill and miles of pvc.

  2. Back To Top    #2
    Mod Squad JohnT's Avatar
    Join Date
    Apr 2007
    Location
    SW Indiana
    Posts
    8,617

    Re: Newly installed Liquidator won't fill with water?!?

    With your large number of returns, you probably have very little pressure. The LQ fills from back pressure, and empties with suction. I would try removing the check valve or looking into another check valve. I tried checking mine by blowing into it, and I can't get it to open. It works fine though, so I can only assume they take a significant amount of pressure to open.
    TFP Moderator
    20K Gallon 20X36 Vinyl Inground
    Hayward S244T Sand Filter with 1HP Whisperflo Pump. Liquidator C-201 and Solar Heat

  3. Back To Top    #3
    TizMe's Avatar
    Join Date
    Aug 2007
    Location
    Covington, Georgia
    Posts
    920

    Re: Newly installed Liquidator won't fill with water?!?

    Seriously thinking on getting a liquidator during the off season so will watch this thread closely for hook up do's and dont's
    Les
    Don't have a pool right now. Just sharing what I have learned over the years!
    Helpful Links:
    Pool School,Pool Calculator,Cl/CYA Shock Chart,TF Test Kit
    Doing BBB and loving it!

  4. Back To Top    #4

    Join Date
    Oct 2007
    Location
    Central Texas
    Posts
    104

    Re: Newly installed Liquidator won't fill with water?!?

    Yes, its definitely a lack of pressure. It resolves as I increase pressure by closing down my master return valve.

    I wonder why the instructions have that line after the filter? I should get higher pressure placing the line before the filter. Has anyone tried this?


    TizMe, there are many good postings on the LQ and most of the trail has already been blazed by the early adopters. Search for Liquidator and read every post if you haven't done so already. Rabbit's posts are must read items IMHO.
    Light grey plaster, stone coping, 38K gallon Roman shaped pool with a shallow end beach, table and bar stools, deep end bench and waterfall (Intelliflo 4X160). Taylor K-2006, Pentair 320 chlorinator, Intelliflow VF, Quad DE 100. 4 ColorLogics, 3 skimmers, 14 wall returns, 13 floor returns, TurboTwister slide, autofill and miles of pvc.

  5. Back To Top    #5

    Join Date
    Mar 2007
    Location
    Virginia Beach
    Posts
    221

    Re: Newly installed Liquidator won't fill with water?!?

    Carlos,

    Since you are an inground pool I would assume that your LQ openings are above water level? If so then there really is no benefit to using the check valves. Rarely I have heard from some who say their pump loses prime when the valves are removed but again that is rare. Removing them will allow you to get a much higher flow rate as well.
    6000 gal inground fiberglass
    1.5hp pump / sand filter
    Liquidator

  6. Back To Top    #6
    spishex's Avatar
    Join Date
    Oct 2008
    Location
    Hillsborough, NC
    Posts
    1,375

    Re: Newly installed Liquidator won't fill with water?!?

    Quote Originally Posted by carlos31

    I wonder why the instructions have that line after the filter? I should get higher pressure placing the line before the filter. Has anyone tried this?
    You might run into some problems with clogged lines if you go that route. That installation just ensures filtered water.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •