Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: cloudy, light green tinted water

  1. Back To Top    #1

    cloudy, light green tinted water

    Ok, I've been reading for a few days here. Call me dense but I need help. I have a pool side bible study for children starting in a week and can't get the pool clear.

    I had it almost clear & my filter split down the side - replaced it, got it almost clear again and my pump went out , ordered a new pump (a bigger one) and now it's been 2 weeks and still cloudy. When I look at it from the side, it has a slight green tint but when I take a sample it's just cloudy. (I can only see cleary about 5" down to the first step.)

    I am also running a newly installed Chlorease SWG. I put in the salt 2 days ago thinking that it would help, it's all dissolved, water is better but still cloudy. When I backwashed this morning, there was no green tint, just very cloudy water.

    I do not know if this is a key, but I had lots of small red worms (well, they are gray now and all dead). I vaccummed to waste for about an hour, the day before I added the salt. Still see a few of them floating around but gray & dead. I do have a few of the usual pool/water bugs but I usually control that with Dawn dish liquid.

    Here are my #
    PH: 7.4
    Alk: 100
    FC: 3
    TC: 3
    Hardness: 100
    CYA: it's a strip so I can't tell (30-50???)
    Salt: 4000

    I know, I need to get a good test kit!! Working on that.

    My pool is a 24' round Above Ground, filter - Jacuzzi Lazer L192C (19", 200 lb sand filter), pump is a Hayward Power Flow Matrix 1.5 HP.

    thanks!!

  2. Back To Top    #2
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,887

    Re: cloudy, light green tinted water

    Welcome to TFP!

    It is really important to know your CYA level more precisely than that! With a SWG you want your CYA level to be up around 70 to 80, but don't adjust it till you get a good reading of the current level.

    There are basically two possibilities, either there is still algae growing or your filter is not working very well, though it could also be both of those things at once. The elimination of the green tint suggests that you have killed all the algae, but it is difficult to be sure without a FAS-DPD chlorine test kit.

    The filter is trickier to diagnose. Have you backwashed recently? When fighting algae you often need to backwash every few days. I am a little concerned that that pump might be too large for that filter, which could cause reduced filtering efficiency. In general you want a larger filter and a smaller pump.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •