Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Cannot get pump to hold prime. Air in return lines

  1. Back To Top    #1

    Cannot get pump to hold prime. Air in return lines

    I have not been able to get my pump to hold a prime for more than a few hours, and it is difficult to get a prime in the first place. I have tried shutting off the main drain line as well as the skimmers, but it still will not hold a prime. I have primed my filter and can get all the air out of it, but when the pump loses prime I can see air in the filter spy glass. It was working for several hours the other day but the pressure increased on the filter due to the first vacuum, so I did a backwash, and it has never been even close to holding one since that. I see lots of tiny air bubbles in my return lines. I have checked the screw in the bottom of the pump and it is tight.
    I have a couple of returns that do not have the eyeball fittings on them yet. There is plaster build up on them and they will not screw in. Also several other of the eyeball are not screwed in flush with the wall. Could this be causing air to get into the system? I can give more info, but wanted to ask about the eyeballs first, because if this is an obvious cause then I should take care of it first. I have tried chiseling the plaster off a screwdriver, but it is hard to get it out from between the threads of the fittings. We were told they didn't need to screw all the way in, but don't know if that is correct. Thanks for any advice.
    Owner/Builder- Pool under construction- Started 4/18/08
    20X40 freeform 3 1/2" to 8 1/2' deep
    elevated 8' spa w/ spillover
    Plaster: Undecided
    Pentair intelliflo
    Pentair intellichlor
    Pentair Mastertemp 400,000 BTU gas heater
    Pentair Triton II 30" sand filter
    LED (probably colorlogic) 3 in main pool and 1 in spa
    Polaris 280 w/ booster pump
    Control System: Still working on this Intellitouch I guess but don't know all the components I need yet.

  2. Back To Top    #2
    Mod Squad JohnT's Avatar
    Join Date
    Apr 2007
    Location
    SW Indiana
    Posts
    8,617

    Re: Cannot get pump to hold prime. Air in return lines

    Air is leaking in, but it isn't on the return side. Air leaks occur on the suction side. Pump strainer basket lid O-rings and drain plug O-rings are common leak points. It could also be caused by a lack of water flow to the pump inlet. Make sure all the drains and skimmers are open.
    TFP Moderator
    20K Gallon 20X36 Vinyl Inground
    Hayward S244T Sand Filter with 1HP Whisperflo Pump. Liquidator C-201 and Solar Heat

  3. Back To Top    #3
    sammm's Avatar
    Join Date
    May 2007
    Location
    North Richland Hills, TX
    Posts
    253

    Re: Cannot get pump to hold prime. Air in return lines

    Another quick check is to turn off your pump while it's running. Look for water squirting out of fittings, valves, etc. There's a suction side leak there if you see that.
    WetEdge Satin Matrix, 16K gallon, Pentair NSP-60 DE filter, Pac Fab Challenger, 2HP pump, BBB, Polaris 360

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •