6/MO Pentair Warrior SE Not working

randdusing

Bronze Supporter
Feb 7, 2021
20
Conroe TX
We had a bad wind storm in Houston today, and I just noticed my robot stopped working as well. I'm going to try cleaning it out and hope it's not an issue with the motor that will require shipping it off for repair.
 

SunnyP2000

Bronze Supporter
LifeTime Supporter
Jul 8, 2013
237
Long Island, NY
Pool Size
17280
Surface
Vinyl
Chlorine
Salt Water Generator
SWG Type
Hayward Aqua Rite Pro (T-15)
We had a bad wind storm in Houston today, and I just noticed my robot stopped working as well. I'm going to try cleaning it out and hope it's not an issue with the motor that will require shipping it off for repair.
when did you get yours?
 

SunnyP2000

Bronze Supporter
LifeTime Supporter
Jul 8, 2013
237
Long Island, NY
Pool Size
17280
Surface
Vinyl
Chlorine
Salt Water Generator
SWG Type
Hayward Aqua Rite Pro (T-15)
I received mine in late March. I inspected the impaler and it looks pretty clean to me. 7 month lifespan is pretty poor :(
same time frame as us. i would start the process asap, it took about 3.5- 4 weeks for whole process . so be prepared to be without a robot for about 4 weeks or so.
 

randdusing

Bronze Supporter
Feb 7, 2021
20
Conroe TX
same time frame as us. i would start the process asap, it took about 3.5- 4 weeks for whole process . so be prepared to be without a robot for about 4 weeks or so.
I sent them an email last night to start the process, so hopefully will hear something back soon. Did you have to call? Luckily I still have my old cleaner somewhere in the garage...
 

SunnyP2000

Bronze Supporter
LifeTime Supporter
Jul 8, 2013
237
Long Island, NY
Pool Size
17280
Surface
Vinyl
Chlorine
Salt Water Generator
SWG Type
Hayward Aqua Rite Pro (T-15)
I sent them an email last night to start the process, so hopefully will hear something back soon. Did you have to call? Luckily I still have my old cleaner somewhere in the garage...
yes called them and spoke to Seth. he usually deals with warranty work.
 

joshscott84

Active member
Apr 21, 2020
43
Tampa Bay
I initially emailed on a Monday and then called the next day when I did not receive a reply. I spoke to Seth as well.

Repair on my unit took about 2-3 weeks. Part of it I was out on vacation though so that worked out. Seems like a bad lot from the manufacturer.
 
Last edited:

Enjoying this content?

Support TFP with a donation.

Give Support

randdusing

Bronze Supporter
Feb 7, 2021
20
Conroe TX
Spoke to Margaret (I believe), and she told me to try unscrewing and "shaking" the motor. She said it sounds silly, but occasionally it works. Did anyone else try it? If not, I'm supposed to call back Monday to begin the warranty claim.
 

wireform

Silver Supporter
In The Industry
Aug 15, 2017
3,118
Spring Valley, NY
Yes this is common especially when new out of the box. Any mishandling and the box got julted once too many can cause the motor to shift enough to cause it not to work. Same can be even not so brand new getting bumped or the like can cause the same. Try it is you only stand to gain.....
 

SunnyP2000

Bronze Supporter
LifeTime Supporter
Jul 8, 2013
237
Long Island, NY
Pool Size
17280
Surface
Vinyl
Chlorine
Salt Water Generator
SWG Type
Hayward Aqua Rite Pro (T-15)
Spoke to Margaret (I believe), and she told me to try unscrewing and "shaking" the motor. She said it sounds silly, but occasionally it works. Did anyone else try it? If not, I'm supposed to call back Monday to begin the warranty claim.
here's the link to video Disengage motor.