Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: New pump room and pump will not prime

  1. Back To Top    #1

    New pump room and pump will not prime

    We just renovated our pump room with three brand new Triton Fiberglass sand filter and a brand new 7 hp pump. We backwashed the other day to test something out and after we put the valves back in place to filter we have no pressure to the filters. We opened the pump and filled it and the lines with water and fired it up and still nothing? I am looking for how to get the filters filtering again because we open in a week. any help would be much appreciated, thanks.

    Ralph
    27' AG w/Deep End ~ 19,060 gallons
    (1 HP Pump, 24" Sand Filter, 7 kids!)

  2. Back To Top    #2

    In the Industry
    duraleigh's Avatar
    Join Date
    Apr 2007
    Location
    Sebring, Florida
    Posts
    28,409
    Ralph,

    Does that big mambo jambo of a pump have a strainer basket and a clear lid like our little 1 hp toys do? If so, is it full of air or water when you turn it on.
    Dave S. - Forum owner
    42k vinyl and concrete pool, 1.5hp pump, 140gpm filter
    TFTestkits , PoolMath , Pool School

  3. Back To Top    #3

    Join Date
    May 2007
    Location
    Rocklin, Ca
    Posts
    467
    Holy Cow! Is this a residential pool? How big?
    11000 Gals, Intelliflo, Sta-Rite Cartridge, Polaris 360

    Pool I built in my old house: my-new-pool-build-t4534.html

  4. Back To Top    #4

    In the Industry
    duraleigh's Avatar
    Join Date
    Apr 2007
    Location
    Sebring, Florida
    Posts
    28,409
    Hello-o-o-o, Ralph. Are you out there?
    Dave S. - Forum owner
    42k vinyl and concrete pool, 1.5hp pump, 140gpm filter
    TFTestkits , PoolMath , Pool School

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •