Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 6 of 6

Thread: Opening Pool, filter drain plug wont go back in?

  1. Back To Top    #1

    Opening Pool, filter drain plug wont go back in?

    Hey guys,

    I am just trying to get my pool open and clear the water up but when I go to screw in my filter's drain plug it doesn't catch the threads to screw in. It's like the threads are gone on the inside of the filter and upon visual inspection there is what looks like rust in and around the drain hole. The drain plug is half threaded and half smooth so I can get the smooth part to slide up inside until the threaded part and I can sit there and attempt to screw it all day and it doesn't go in.

    Has anyone else ever had this problem? I am thinking that I might have to find an all smooth plug and somehow seal the hole with some kind of plumbers paste so it doesn't leak.

    If anyone can help me out with suggestions that would be great, Thanks!
    12,500 Gallon Fiberglas spool
    Hayward S210 Sand filter
    Hayward Superpump

    Tulsa OK
    been using BBB since April 2008

    Guess What?????
    BEEN ALGAE FREE SINCE APRIL 2008

  2. Back To Top    #2

    In the Industry
    duraleigh's Avatar
    Join Date
    Apr 2007
    Location
    Sebring, Florida
    Posts
    28,392
    Brand, type and model of filter?
    Dave S. - Forum owner
    42k vinyl and concrete pool, 1.5hp pump, 140gpm filter
    TFTestkits , PoolMath , Pool School

  3. Back To Top    #3
    It is a SwimQuip sand filter, not sure of the model (label ripped on filter), but its about 4 feet high and a couple feet in diameter, and I would guess it's at least 5-10 years old.

    Thanks again.
    12,500 Gallon Fiberglas spool
    Hayward S210 Sand filter
    Hayward Superpump

    Tulsa OK
    been using BBB since April 2008

    Guess What?????
    BEEN ALGAE FREE SINCE APRIL 2008

  4. Back To Top    #4
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,887
    I had that happen to me on my heater. I had to retap the threads to get it to work again.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  5. Back To Top    #5

  6. Back To Top    #6
    Well I just kinda banged the plug up in there and its not leaking anymore so we'll see how it holds up. Retapping the hole would be my next option though.

    Thanks for the help!
    12,500 Gallon Fiberglas spool
    Hayward S210 Sand filter
    Hayward Superpump

    Tulsa OK
    been using BBB since April 2008

    Guess What?????
    BEEN ALGAE FREE SINCE APRIL 2008

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •