Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Schizophrenic Aquatrol

  1. Back To Top    #1

    Schizophrenic Aquatrol

    Hi - I have an Aquatrol RJ for a 15k gal AGP and it has been working fine for 6 years. After about 3 years we had to replace the cell. That one went in 2 years, 11 months, and 20 days ... the 'check salt' led came on steady even though we keep the salt at optimum levels (2800-3100). We checked the salt at a pool store and it was right at 3000. We replaced the cell and it worked for a week so we figured that was the problem.

    A week later, we left for vacation and, of course, during the week we were on vacation, the Aquatrol quit working and we came home to a green pool. The "no flow" led was on steady. The pump was not on (not running). We plugged the pump directly into an AC outlet and the pump runs fine. However, even with the pump running, the Aquatol "on" and "no flow" leds are on but the rest are off (including the "check salt" led).

    I checked the electrionic components ( 20a fuse, rectifiers, relays, capacitors, etc.) and everything seems fine. Since this is an AGP "RJ" unit there is no flow switch. As a test, I plugged an RJ-5 into the flow switch jack on the bottom of the unit with the center two pins shorted. The "no flow" led blinked for a few seconds and went out. Then the "generating" light came on. There are fine bubbles at the pool return fitting which is normal when the unit it generating. There is still no voltage at the output plug on the bottom of the unit for the pump.

    I cycled through the displays to make sure salt, temp, etc were within tolerance. The readings are:

    3000 (ppm)
    84 (degrees F)
    26.2 (volts while geneating)
    4.14 (amps while generating)
    98P (percent on)
    -3100 (ppm instantanerous)
    AL-0 (??? what is this?) <<<<<---------------------
    r1.33 (sw version)

    Usually the code for my unit is AL-7, not AL-0. I don't know what AL-0 means or what the software thinks this unit is. Maybe an inground unit? Could explain why it sees no flow without a flow unit input and why the pool motor plug doesn't have any voltage at it since an ingroung pump is usually wired to its own external timer.

    As I said, the unit seems to be chlorinating with the pump in a separate AC outlet and a shorted RJ5 plug jury rigged into the bottom of the unit.

    Is there a way to hard reset this board so it knows it's an Aquatrol RJ for an AGP and the pump outlet works according to the built in timer settings?? Right now it is running on an external timers along with the pump. Will this hurt anything? I hate to buy a whole new PCB when everything on it physically seems to be working fine ... the software just needs a "reset" of some kind. Over the many years we've had this unit we have had power outages, lightning storms, hurricanes even, and the unit didn't seem to be affected. I'm wondering if the new cell had some bearing on this software glitch or if it's something I'm totally unaware of that can be easily fixed. The new cells cost me $350 (I should have run it under warranty) and a new board is $250 ... a whole new unit streets for about $470. Someone please tell me there is a simple reset procedure us mere mortals don't know about. Thanks!

  2. Back To Top    #2
    JasonLion's Avatar
    Join Date
    May 2007
    Silver Spring, MD

    Re: Schizophrenic Aquatrol

    Welcome to TFP!

    It seems to have forgotten that it is an RJ model. I think you can change that by pressing the diagnostic button till it shows AL-0, the switch to super chlorinate and then back to auto. If I am remembering correctly that will let you cycle to AL-6, and then again to get to AL-7, at which point it should start working again.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  3. Back To Top    #3

    Re: Schizophrenic Aquatrol

    Thanks for the welcome and the quick reply! I ran outside to try what you suggested full of hope. But alas, pressing the diagnostic button until AL-0 showed in the lcd and switching the slide switch from auto to super chlorinate and back to auto did not change the "AL-0" in the lcd to anything different ... and now, the "no flow" led is on again and the "generating" led is off. I double checked the connections on the shorting RJ5 jack to make sure they were still ok. The unit does not appear to be chlorinating now (no small bubbles at the oulet) and the "generating" led is not on. Only the "on" and "no flow" led's are on. I also tried what you suggested but held in the diagnostic button while sliding the superchlorinate to auto switch but this also had no effect. Now I'm really baffled why the shorting RJ5 no longer works to at least get the thing chlorinating.

    [EDIT] Belay that last part ... I just checked it again and the "no flow" led went out and the "generating" led is on again and there are small bubbles at the outlet. So at least it is working as well as before ... no harm done. (phew!)

    Appreciate your trying to help!! This thing is so close to "working" pefectly that I'm hopeful it doesn't require a whole new expensive PCB. I take it the firmware is not in an eeprom since I didn't see anything that looked like a backup battery in there.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts