Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 5 of 5

Thread: filter pressure on spa mode

  1. Back To Top    #1

    filter pressure on spa mode

    I just installed a new filter and pump. Pentair Cart Filter 320sq and a whisperflo 1.5hp pump.
    I used 2" piping thru out.

    When I set the return to only the spa, the pressure in the filter jumps by 15-18psi, goes from 15psi to about 30-32psi.
    The spa is small only has 4 jets

    Is this normal or okay for the filter?

    thanks
    25K Pool Kidney Shape
    Spa
    Water Slide
    320Sqft Pentair Clean and Clear Cart Filter
    1.5hp Pentair WhisperFlo pump
    400k BTU Hayward LoNox Heater

  2. Back To Top    #2

    Join Date
    May 2007
    Location
    Carrollton, TX
    Posts
    113
    You may want to check out this discussion I had a while back:

    http://www.troublefreepool.com/viewtopi ... highlight=

    I have decided to look into getting an Ikeric variable speed pump.
    7000 gallon IG freeform w/ 6 ft. spa, 21 ft weeping wall, Hayward SP4020NS Northstar pump, Colorlogic LED’s, DE6020 filter and H400IDL2 400,000btu heater. Aqua logic 8 zone controller with Aqua Rite salt chlorine generator, Stonescapes pebble finish – Aqua Blue and flagstone coping, stamped/stained concrete deck

  3. Back To Top    #3
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,887
    That sounds like one of the Clean and Clear series of filters. They are rated for a maximum pressure of 50 PSI. You are well under that so there shouldn't be any damage.

    The pump is probably too large for the number of jets you have. The pump is trying to move more water than the jets want to let through so the pressure builds up until the flow rate goes down to something the jets can handle. Nothing will really go wrong, you are just wasting electricity running a larger pump than you really need.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  4. Back To Top    #4
    That's way too much pump for that filter. Sure they are rated for the flow but in a real world it's just not true. Sounds like your builder went the cheap way and did not want to spend another $80 for the 420 filter. Four jets, 320 and 1.5 whisperflo is a bad combo. It will use more energy and your ongoing symptoms are going to be premature wear on the cartridges and possibly some bearing damage on the motor. Those are all typical wear issues on a system like this. The 15 daily operation psi is not too bad so you won't see a ton of early wear. It's all going to be relative to your spa usage. You could actually swap out the motor for a variable speed version and increase your jet flow by reducing pump speed.
    Authorized IntelliFlo Installer

  5. Back To Top    #5
    yes i agree that the pump is a little too powerful. I actually found out that if I adjust the valves a little so that at least some water goes to the pool the pressure only increases to 20psi.
    The force of the water coming from the spa jets is still very good.

    I will probably add a blower to make it more bubbly. There is an extra 2" pipe coming out of the equipment pad that i think is for a blower. Do you have any recomendations on how i can figure out where that extra pipe leads? Maybe attach a leaf blower and see where the air goes?
    25K Pool Kidney Shape
    Spa
    Water Slide
    320Sqft Pentair Clean and Clear Cart Filter
    1.5hp Pentair WhisperFlo pump
    400k BTU Hayward LoNox Heater

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •