Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Sand filter question [SD80]

  1. Back To Top    #1

    Sand filter question [SD80]

    I can "hear" water swishing through the sand filter -- is that normal?

    Also, is there a way to determine how much pressure I should be seeing with my setup? At 40GPM, I'm seeing about 14-15PSI. At 20PSI, I backwash. If I up that to 50GPM, it averages around 20PSI.

    If I go to 75GPM, it averages 30PSI. I want to run at this rate but the SD80 maxes out at 35PSI.

    Steve
    20x40 Kafko pool, Pentaire SD80 filter, Intelliflow pump, 8 foot deep end, Autopilot

  2. Back To Top    #2

    Join Date
    Mar 2007
    Location
    Ontario, Canada
    Posts
    294
    I have the SD-80 with a Pentair Superflo 1.5 HP motor. I can hear water swishing and some sand hitting the sides when I turn the pump on when it has been off. But normally there is no swishing. Maybe you have an air caught in the filter. There is a small dark screw below the pipe that runs from the pump to the top of the multiport valve that will bleed any air out of your system. you can give that a try while its running. As for pump pressure, I only have one speed and I am not sure what my GPM is. My normal running pressure is around 16 psi, I usually backwash at 19. It has never gone over 20.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •