Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Base of Multiport Leaking Water

  1. Back To Top    #1

    Join Date
    Jun 2009
    Location
    Russellville, Arkansas
    Posts
    4

    Base of Multiport Leaking Water

    For the first month of the season I had no problems with my Eco Kleer multiport filter. Then, last weekend, it started leaking a significant amount of water from the base of the multiport and the water tank, enough to visibly drop the water level before it was noticed. The pump and filter are still pushing enough water to recirculate. I tightened the connection (no help), removed the multiport and reset the o-ring and retightened. No help. Could this be an o-ring failure? What would cause water from the water tank to start leaking significantly overnight? Thanks!
    AG Miramar 27'x54" (Not yet installed).

  2. Back To Top    #2
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    21,774

    Re: Base of Multiport Leaking Water

    It could be a crack on the neck of the vessel or the multiport. A close inspection should tell you where it's leaking from. It could also just be that the o-ring is old and needs replacing.

    Did you lube the o-ring when you removed and replaced it?
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  3. Back To Top    #3

    Join Date
    Jun 2009
    Location
    Russellville, Arkansas
    Posts
    4

    Re: Base of Multiport Leaking Water

    I'll check for a crack. I haven't replaced the o-ring. The only time I've exposed it since installed the pool last July was to replace sand this spring. I did not lubricate when I put it back in place. The o-ring does appear to not be completely circular. I am surprised at how it is just not leaking but putting water out under pressure from the base of the multiport. Barring no cracks, my first option should be to replace the o-ring? Thanks!
    AG Miramar 27'x54" (Not yet installed).

  4. Back To Top    #4
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    21,774

    Re: Base of Multiport Leaking Water

    Your first option should be to open it up and lube the o-ring and put it back together correctly.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •