Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 8 of 8

Thread: Pump Pressure after a Aqua Trol Install

  1. Back To Top    #1

    Pump Pressure after a Aqua Trol Install

    Hello all,
    I am new to this forum as I am also a new pool owner.
    I have a oval 10.5gal Above ground pool.
    I have a basic question.

    The water was flowing evenly at 10psi on the gauge before I just installed a Aqua Trol Return jet type.
    Now it seems to sit at 0 and work its way up to 10 or so then drop back down. It does not have a nice even flow as it did before the install.

    Is this normal or is there something wrong here?

    Thanks for any help to a noob.

    Steve

  2. Back To Top    #2

    Join Date
    Jul 2008
    Location
    Solon, Iowa
    Posts
    170

    Re: Pump Pressure after a Aqua Trol Install

    Something is wrong somewhere. A properly installed Aqua Trol shouldn't cause that kind of behavior. Stick around and I'm sure that you will get some expert advice soon.
    15X30 AGP, Lomart beaded liner;
    1.5 HP Sta-Rite pump with 21 inch sand filter (Zeobrite media)
    Mineral Springs (Aquatrol) SWCG, Rigid PVC plumbing, 2 inch
    Four 4X12 Techno-Solis solar panels, rack mounted, Goldline Solar Controller

  3. Back To Top    #3
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    21,774

    Re: Pump Pressure after a Aqua Trol Install

    Welcome to TFP.

    I hope you meant 10.5Kgal pool! Just had to rib you a little.

    Does the pump basket stay full of water all the time?
    Did any of the valves seem like they didn't open completely when you reopened them after the install.
    Is the skimmer weir operating freely and is it creating a vortex in the skimmer?
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  4. Back To Top    #4

    Re: Pump Pressure after a Aqua Trol Install

    I think I may have jumped the gun a little.

    I have had the unit running now since this morning and it seem to be doing better.
    As it does not hold a steady point on the pump gauge it is not setting at 0 anymore than jumping to 10.
    The pressure is fluctuating a bit more than without the aqua trol but it is definitely moving the water and no longer setting at 0 at all.

    Yea I did mean 10.5K. Don't mind the ribbing thats what keeps forums like these fun.

    Thanks

    Steve

  5. Back To Top    #5
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,887

    Re: Pump Pressure after a Aqua Trol Install

    Check the skimmer and make sure the water in the pool is deep enough that the skimmer is getting plenty of water. When the water is a little low, the skimmer can draw in air, which causes the pump to stumble for a moment and can cause the pressure fluctuation you describe.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  6. Back To Top    #6

    Re: Pump Pressure after a Aqua Trol Install

    Quote Originally Posted by Bama Rambler
    Welcome to TFP.

    I hope you meant 10.5Kgal pool! Just had to rib you a little.

    Does the pump basket stay full of water all the time?
    Did any of the valves seem like they didn't open completely when you reopened them after the install.
    Is the skimmer weir operating freely and is it creating a vortex in the skimmer?

    The pump basket does not stay full that is the problem it fill up then purges the water through the system.
    I think I have a air leak but not sure where it could be.

    Can I run it in this condition?(until I get it fixed)
    It does move the water just not efficiently.

    Suggestions?

    Thanks

  7. Back To Top    #7
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    21,774

    Re: Pump Pressure after a Aqua Trol Install

    A few likely causes of the pump basket doing that are;
    1. An air leak at the pump basket lid[/*:m:2v4t32qh]
    2. The skimmer weir could be sticking[/*:m:2v4t32qh]
    3. The water level could be low causing the skimmer to create a vortex and suck in air[/*:m:2v4t32qh]
    4. The skimmer line could have a restriction[/*:m:2v4t32qh]
    5. There could be a leak in the suction piping.[/*:m:2v4t32qh]
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  8. Back To Top    #8

    Re: Pump Pressure after a Aqua Trol Install

    O-ring lube, O-ring lube.
    Wow what a small thing but that is what it was. As a noob and my installer/sales team did not give me an real info on how to maintain the system I am relying on this board and my local pool supply store to help.

    Thank you all.
    Steve

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •