Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 5 of 5

Thread: Hayward Xstream Problem

  1. Back To Top    #1

    Hayward Xstream Problem

    Hi everyone,
    I'm a newbe here and was looking for help with a problem I'm having with my filter. I've had the AGP now for 4 years and last year the cover on the Hayward Xstream became harder and harder to remove and reinstall, now its leaking and I cannot get it on tight enough. Last year I replaced the cover o-ring since it had stretched.

    any help with this problem would be great

    Thanks
    Pete
    24' Round - Hayward Sand Filter - 1.5HP Hayward Power Flo MatriX Pump - Intex SWG

  2. Back To Top    #2

    Join Date
    May 2007
    Location
    South Central NJ
    Posts
    3,192

    Re: Hayward Xstream Problem

    1) Ensure all surfaces are cleaned of dirt.
    2) Debur any nicks or small gouges.
    3) Use Magic Lube or Jack's 327 lube on the o-rings. Not a lot, but enough to prevent the o-ring from twisting or getting hung and stretching.
    4) A toothbrush to clean off dirt is your friend. When it's time to replace your personal toothbrush, save the old one for this purpose.
    5) Replace O-Rings when needed.

    Scott
    Owner of - PoolGuyNJ LLC
    Expert Pool and Spa Repairs, Renovations, and Augmentation. Helping people decide what is the right gear for meeting their needs. Expectations Set, Expectations Met, No Surprises.

  3. Back To Top    #3

    Re: Hayward Xstream Problem

    Thanks PoolGuyNJ

    I will be working on it today and see if it works out.
    24' Round - Hayward Sand Filter - 1.5HP Hayward Power Flo MatriX Pump - Intex SWG

  4. Back To Top    #4
    mcoonan's Avatar
    Join Date
    Aug 2008
    Location
    Mendota Heights, MN
    Posts
    292

    Re: Hayward Xstream Problem

    Pete,
    I have the same filter, every year I use a small scrub brush (like a nail brush but bigger than a tooth brush) and some regular dish soap (we use Dawn) to scrub the filter housing and threads on the bellyband. Lube up the o-ring with some Jacks or similar silicone lube and assemble.
    Intex Ultra 18' x 52" AG 6,981 Gal.
    3 - 2'x20' solar panels
    Hayward XStream 1500 Cart Filter
    Hayward 1-1/2 HP 2-speed Superpump
    Aquabot Pool Rover
    2-Softub 300 hot tubs (yup just got one for the lake)
    TF Test Kit Doing the BBB for 7 years
    Medota Heights,Minnesota

  5. Back To Top    #5

    Re: Hayward Xstream Problem

    Thanks PoolGuyNJ

    Worked Great!!
    24' Round - Hayward Sand Filter - 1.5HP Hayward Power Flo MatriX Pump - Intex SWG

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •