Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 6 of 6

Thread: Any advice for my newly broken multiport valve?

  1. Back To Top    #1

    Join Date
    Mar 2009
    Location
    Midwest
    Posts
    101

    Any advice for my newly broken multiport valve?

    I'm still a newbie, and I screwed up and switched the valve while the pump was running. Water squirted out while switching it, and now it's not working. Initially I switched from Filter to Closed and then switched to Waste and back to Closed, before realizing the mistake.

    I was wondering if there is anything DIY that I should try before I call and hire a pool repair expert. Also, if I call, maybe you can tell me approx how much this should cost to fix or how to know if the guy is giving me an OK price?

    I think I need it fixed ASAP because every day of the pool sitting there with no filtration is going to end up costing me (more time and cost for chemicals)? I was just going to vac the pool and then do a major shock of keeping the chlorine high for 24+ hours, and then go swimming.

    It is a Hayward vari-flow XL valve and my entire system was verified to be functioning before I did this to it. Now it won't achieve suction and doesn't have water in the pipes apparently. My friend tried to put water in there with no luck?

    I read that the gasket can get unseated/unsealed... might that be all that's wrong? Is it a bad idea to get a friend (who has no pool knowledge but has average general handyman knowledge) to open it up and see if the seal is bad, and reseal it if so?

    Thanks a bunch as usual!
    Inground oval approx 17.5' x 35' (with middle of deep end 9'?) so guessing 27000 gallons. Vinyl liner, BBB chlorine. Dolphin. Portable fullsize spa not currently in use.

  2. Back To Top    #2
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    21,774

    Re: Any advice for my newly broken multiport valve?

    You most likely unseated the spider gasket. It's not too hard to replace it and the shaft seals if they're leaking. You and your handy friend could easily repair it.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  3. Back To Top    #3

    Join Date
    Mar 2009
    Location
    Midwest
    Posts
    101

    Re: Any advice for my newly broken multiport valve?

    Whew, I hope so. So ummm... shouldn't be hard to figure out how to open it up? And figure out which need resealing? If they are unseated, all I need is to get some sealant, no special tools or replacement parts, and see if that works?
    Inground oval approx 17.5' x 35' (with middle of deep end 9'?) so guessing 27000 gallons. Vinyl liner, BBB chlorine. Dolphin. Portable fullsize spa not currently in use.

  4. Back To Top    #4
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    21,774

    Re: Any advice for my newly broken multiport valve?

    You can search for a manual on the web if you don't have one that'll show you an exploded view. Sealant and silicon lube,
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  5. Back To Top    #5

    Join Date
    Mar 2009
    Location
    Midwest
    Posts
    101

    Re: Any advice for my newly broken multiport valve?

    Well, upon unscrewing the top, I don't see anything to repair. All I see is a large black o-ring that looks to be in excellent condition, and then underneath there's a gummy yellowish seal to divide each 'pie wedge' part, and that looks fine as well. When I turn on the filter, I am getting air bubbles coming out of one jet, and nothing coming out of the 2nd jet. So I guess that means there is some leak in the pump system. Time to get an expert out here......?
    Inground oval approx 17.5' x 35' (with middle of deep end 9'?) so guessing 27000 gallons. Vinyl liner, BBB chlorine. Dolphin. Portable fullsize spa not currently in use.

  6. Back To Top    #6

    Join Date
    Mar 2009
    Location
    Midwest
    Posts
    101

    Re: Any advice for my newly broken multiport valve?

    Nevermind, it's working! Was simply leaking near that other seal near the glass.
    Inground oval approx 17.5' x 35' (with middle of deep end 9'?) so guessing 27000 gallons. Vinyl liner, BBB chlorine. Dolphin. Portable fullsize spa not currently in use.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •