Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 5 of 5

Thread: Sta-Rite Pool Heater Problem

  1. Back To Top    #1

    Sta-Rite Pool Heater Problem

    I have a Sta-Rite NA400 Natural Gas. This is it's 5th season. Last year in September 2009 the heater started to turn off after 30-45 seconds. It would ignite, heat, and shut down. Control board AFS light is lit. Also there is one flashing light in the Control Box grey panel. I replaced the AFS switch and the Thermal Regulator. Also replaced the wiring harness since most wires were chewed from mice and I had spliced them. The exhaust is blowing warm and fairly forceful. Sta-Rite tech support said that it sounds like a blower whci as you know is an expensive part to try out. Any ideas would be appreciated.
    16X32 Rectangular In Ground Built 1998, New Vinyl liner and Motor 8/2012, 19,000, Hayward Sand Filter, Hayward Super Pump,PoolPilot DIG-220 SWG, 2 Skimmers, Main Drain, Clean Machine Robot, Full Sun, Bleach, TFTest Kit
    Central, VA

  2. Back To Top    #2
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,887

    Re: Sta-Rite Pool Heater Problem

    Welcome to TFP!

    I can't answer your question. I just wanted to say hi! Hopefully someone who knows more about heaters will be along soon.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  3. Back To Top    #3
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    21,778

    Re: Sta-Rite Pool Heater Problem

    Have you tried lubing the blower bearings? Checking the cage for blockage might be something to do as well.

    You could check the rpm's if you have a tach handy. Some of those air flow switches are pretty sensitive and if the flow sags just a bit they'll trip.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  4. Back To Top    #4

    Join Date
    Mar 2007
    Location
    Coastalish 'down easter'
    Posts
    4,160

    Re: Sta-Rite Pool Heater Problem

    Welcome to TFP!!

    I know these heaters VERY well.

    You've has a mouse issue (infamous for these units) and I believe that there is a 'mouse house' in the blower unit that just needs to be removed so that it can do it's job, without constriction.

    I can walk you through checking this, if you need
    Luv& Luk
    -Ted

    Having done construction and service for 4 pool companies in 4 states starting in 1988, what I know about pools could fill a couple of books - what I don't know could fill a couple of libraries :-D

    POOL SCHOOL, TF Testkits, Jason's Pool Calculator, CYA vs. cl chart, (Just a few DARNED handy links!)

  5. Back To Top    #5

    Re: Sta-Rite Pool Heater Problem

    If you can give me some instructions I'll give it a try..
    16X32 Rectangular In Ground Built 1998, New Vinyl liner and Motor 8/2012, 19,000, Hayward Sand Filter, Hayward Super Pump,PoolPilot DIG-220 SWG, 2 Skimmers, Main Drain, Clean Machine Robot, Full Sun, Bleach, TFTest Kit
    Central, VA

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •