Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Chlorinator issues

  1. Back To Top    #1

    Join Date
    May 2010
    Location
    Connecticut
    Posts
    2

    Chlorinator issues

    Hi all...first time posting!

    We recently had an 18' above ground pool installed on our property (we had a 21' that we had to return due to issues with zoning, etc....boo!) So, this past weekend we figured we'd fill the pool to capacity and switch on the filter to get things circulating. As soon as the water reached the skimmer level, our ProLine chlorinator quickly started gushing gallons of water from the top. We shut off the ball valves on each side, drained the chlorinator, cleaned up the flood, and replaced the top. Opened the valves again and we had the same issue.

    After a bit of research, I realized that the pool installers didn't put in the cover O ring...so we called the pool store and we picked another up. We just put the O ring in and we're experiencing more gushing. Now it looks as if water is leaking from the control valve as well.

    There is a serious lack of information on the ProLine chlorinator on the web and the 2 page owners guide is less than helpful.

    I'm hoping someone can help us figure this out here...thanks so much for reading and any help you could give us!
    *Leah*
    18' x 52" AG/DE filter with 1.5 HP pump/ProLine chlorinator/RayPak 130K BTU propane heater

  2. Back To Top    #2

    Re: Chlorinator issues

    I just recently installed a Zokiac LM3 chlorinator and experienced the same problem. The o-ring was there but was not seated properly in the groove cut out for it. After some tweaking and patience, I finally got the o-ring lined up properly and the cell reinserted with no leak.
    Check the o-ring alignment thoroughly before you give up.
    mrgaddy
    _______
    28K gal, vinyl, 1 HP pump, Hayward S244T, Zodiac LM3 SWG, Polaris 3900 Pool Cleaner with Booster(1/2HP)

  3. Back To Top    #3

    Join Date
    Feb 2008
    Location
    Flower Mound, TX
    Posts
    5,062

    Re: Chlorinator issues

    Hi Leah, welcome to TFP!

    Is this a chlorine tablet feeder that you are talking about?
    10K gallon IG gunite with waterfall; Pentair CC320P filter; WhisperFlo 2 HP pump
    TF Test Kits - Pool Math - Pool School
    "It depends."- JohnT

  4. Back To Top    #4

    Join Date
    May 2010
    Location
    Connecticut
    Posts
    2

    Re: Chlorinator issues

    mrgdaddy: We tried the o-ring every which way and it still just doesn't work...it's just like there is not enough pressure to hold the top on. It's very easily removable.

    257: Thanks for the welcome! Yes, it's a tablet feeder.
    *Leah*
    18' x 52" AG/DE filter with 1.5 HP pump/ProLine chlorinator/RayPak 130K BTU propane heater

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •