2019 pentair ic issues thread

jimim

Bronze Supporter
Jun 20, 2016
2,445
NE/Pa
Figured I would start the summer pentair ic issue thread. Haha

Well once again I have a bad “flow switch”. Water is 70 now and cell reads 2500 when actual from Taylor is 3400.

I called. New flow switch coming out. This cell is only like 3 months of use on it and then stored for the winter.

Soooo pentair said all the flow switch issues and 0 readings from last year are because the people who make the flow switch for them.

The one I’m getting is from a different manufacturer.

We will see.

Anyone with issues this year post them here and maybe we can keep them all in once place vs 300 threads popping up.

Jimi
 

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
14,389
Bedford, TX
Jimi,

We will see... I can understand how a bad thermister will cause the cell to report the wrong salt level, but my bet is that this will not fix the zero readings....

Thanks,

Jim R.
 

jimim

Bronze Supporter
Jun 20, 2016
2,445
NE/Pa
I agree. I’m more ticked off I have to get splice another flow switch. So in 2 seasons. Like literally 10 months of use I have replaced 2 flow switches and I’m on my second unit.
 

jimim

Bronze Supporter
Jun 20, 2016
2,445
NE/Pa
Well figured I would bring this thread up again to try and throw all the ic problems in one place but anyway.

They sent me a whole new unit vs a flow switch. My builder came over tonight and we threw it in. My actual Taylor reading is 3200. Cell is reading 2850. Ah not great but it’s happy for now. I looked back to last year. To keep it happy I pretty much had to run actual level at 3600. I’m not going to add anymore salt till it isn’t happy again.

@Jimrahbe My cya is 50-60 right now. I didn’t get a change to get it up to 70 yet. That ok to run it still not being at 70? I know the pool school says 70-80 is best. 60 is there but not recommended.

Just wondering.
Thanks!
Jim


Ps. I’m having a fire sale of ic40’s. I got 1 unit that gives u a zero reading but is perfectly clean and only was used for literally 3 months. I also got a unit that was used for like 2 months and it gives a low reading. Would work for anyone who likes to run thier salt pretty hot. Haha. I got a few flow switches too. Haha
 

Jimrahbe

Mod Squad
TFP Expert
LifeTime Supporter
Jul 7, 2014
14,389
Bedford, TX
Jimi,

You can run with a CYA of 30 if you want, you will just have to run the cell harder.. The higher the CYA the less FC the sun will burn off.. 50 or 60 this time a year will work fine... I would just keep the cells.. The one that reads zero still works fine and you could use it, even if just temporarily in case you ever need to.. It would also be great to use as a troubleshooting tool.

Thanks,

Jim R.
 

jimim

Bronze Supporter
Jun 20, 2016
2,445
NE/Pa
Thanks Jim! Ok thats what I thought about the cya. Right now I loose 2 ppm a day for the past week. I’ll get it up this week when it’s nice out.

The fire sale what kinda joke to show the collection I’m building up. Crazy how I’m running through these. Ya the one that reads zero will be my replacement when I go out of warranty so I don’t have to buy one.

Funny how they sent me a new one vs a flow switch. According to them the new manufacturer for the flow switch will fix all the issues. Im glad they have been so great and easy to deal with.