Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Leaky O-ring on Hayward Sand Filter

  1. Back To Top    #1

    Join Date
    Apr 2010
    Location
    Central Kentucky
    Posts
    43

    Leaky O-ring on Hayward Sand Filter

    Help, I have a leak on my Hayward S1700 sand filter. It is the o-ring on the multi port valve part # GM600F which I just replaced and it is still leaking about 1 drop every 1-1/2 seconds. Like I said, I replaced the o-ring and it still leaked, so I removed it again, wiped everything dry and coated the filter body with KY Jelly hopeful to make a seal. Well, it didn't work and it still leaks at the same rate.
    I was wondering if I should get something like a gasket seal compound from an auto store. What do I do? The old ring was intack and looks as good as the new one.

    Any suggestions????please....



    Thanks
    ff
    Intek 15' diameter X 4'deep 4,800 gallon AG beginner pool, updated with a Hayward sand filter, 60GPM pump. TF-50 Test Kit. Upgraded to TK-100

  2. Back To Top    #2
    InTooDeep's Avatar
    Join Date
    Apr 2010
    Location
    Lake Wallenpaupack, PA
    Posts
    9

    Re: Leaky O-ring on Hayward Sand Filter

    Hmm, not sure about KY Jelly for pool lube ...I've always used Jack's on my Hayward E200 sand filter O-ring with good results.
    24' Round A/G 14,500 gallons, Hayward HeatPro HPABG Deluxe 60K BTU heat pump, Hayward EC50AC DE filter w/1HP Matrix Pump

  3. Back To Top    #3
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,887

    Re: Leaky O-ring on Hayward Sand Filter

    You want to use a silicone based pool/plumbers lubricant, such as the one InTooDeep suggested. You should also check the o-ring for nicks and cuts.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  4. Back To Top    #4

    Join Date
    Apr 2010
    Location
    Central Kentucky
    Posts
    43

    Re: Leaky O-ring on Hayward Sand Filter

    Thanks, I fixed it using plumbers silicon bought from the plumbing area of my local lowes. cost 3 bucks
    Intek 15' diameter X 4'deep 4,800 gallon AG beginner pool, updated with a Hayward sand filter, 60GPM pump. TF-50 Test Kit. Upgraded to TK-100

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •