Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 13 of 13

Thread: Question about my filter

  1. Back To Top    #1

    Join Date
    Mar 2010
    Location
    Spring, TX
    Posts
    1,082

    Question about my filter

    Ok I took the plunge and cleaned the filter myself. It is a DE Natilus filter. I took it all apart and boy did it have a lot of built up DE inside. So got it all cleaned off, cleaned each grid and all parts. Pulled out the drain plug and it has what looked like a black seal on the inside. So I took the plug out so the remaining dirty water in the bottom of the pump could drain. So got it all put back together and have some questions.

    1. My pressure is in between 0 and 10. This is the first time for a full take apart. Usually when I backwash my pressure drops down a little below 10. So I assume this pressure between 0 and 10 for a full take apart is ok.

    2. Second question is when I put the drain plug back in I made it as tight as I could. Around the drain plug there is a slow leak. What do I need to do to fix this? Do I need to pull a sealant around the inside of the plug or do I need a new one?

    3. I got it all put back together and I have 4 places around the top and bottom that are leaking. Is this the sign that I need a new round seal or is there something else I need to do? I took it apart and put it back together and still have the leaks. I thought maybe I had not got something tight enough but it did it again the 2nd time around as well.

    4. Also having a hard time determining how tight to put the screws around the metal round part that you put on last.

    If pictures would help I can get pictures as well.

    Thanks for all the help.
    13,000 Plaster IG Pool approx
    Hayward C5030 Cart Filter
    Emerson 1081 EB653 1.0 HP 1.40 S.F. 3450 RPM
    Pool Calculator, Pool School, TF Test Kits

  2. Back To Top    #2
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,887

    Re: Question about my filter

    1) Yes, the pressure should be lower than it was before.
    2) I would try some teflon plumbers tape around the threads.
    3) You probably need to clean and lubricate the rubber sealing ring with a silicone based lubricant.
    4) Quite tight, "push really hard on the end of the wrench but don't jump up and down on it". I don't know how else to put that in words. Perhaps someone else can come up with a better description. It is also possible that your manual has a more useful way of describing it.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  3. Back To Top    #3

    Join Date
    Mar 2010
    Location
    Spring, TX
    Posts
    1,082

    Re: Question about my filter

    Quote Originally Posted by JasonLion
    1) Yes, the pressure should be lower than it was before.
    2) I would try some teflon plumbers tape around the threads.
    3) You probably need to clean and lubricate the rubber sealing ring with a silicone based lubricant.
    4) Quite tight, "push really hard on the end of the wrench but don't jump up and down on it". I don't know how else to put that in words. Perhaps someone else can come up with a better description. It is also possible that your manual has a more useful way of describing it.
    Will this work for #3

    http://www.homedepot.com/h_d1/N-5yc1vZ1 ... ogId=10053

    http://www.lowes.com/pd_124699-39963-D0 ... t=silicone
    13,000 Plaster IG Pool approx
    Hayward C5030 Cart Filter
    Emerson 1081 EB653 1.0 HP 1.40 S.F. 3450 RPM
    Pool Calculator, Pool School, TF Test Kits

  4. Back To Top    #4
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,887

    Re: Question about my filter

    The Home Depot version is exactly what I was thinking of. I don't like the spray, it seems to get everywhere except where you want it.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  5. Back To Top    #5
    MikeInTN's Avatar
    Join Date
    May 2007
    Location
    Middle Tennessee
    Posts
    1,335

    Re: Question about my filter

    Aladdin o-ring silicone lube is good stuff, too.

    http://www.pfpros.com/pond-liners-aladdin.shtml
    24' x 52" AGP - approx 13,500 gallons
    Pentair Optiflo 1 hp/2sp pump w/ Swimpro Voyager 150 sq ft cartridge filter
    Intex 8110 SWCG
    "Fear the Schnauz!"

  6. Back To Top    #6

    Join Date
    Mar 2010
    Location
    Spring, TX
    Posts
    1,082

    Re: Question about my filter

    Quote Originally Posted by JasonLion
    The Home Depot version is exactly what I was thinking of. I don't like the spray, it seems to get everywhere except where you want it.
    I guess when I am doing it, I should lube the whole o ring part? I noticed that when I took it apart there was some stick stuff on top and bottom of the ring. Hopefully with your help I can get rid of the leaking.
    13,000 Plaster IG Pool approx
    Hayward C5030 Cart Filter
    Emerson 1081 EB653 1.0 HP 1.40 S.F. 3450 RPM
    Pool Calculator, Pool School, TF Test Kits

  7. Back To Top    #7
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,887

    Re: Question about my filter

    Yes the entire O-ring (and all of the other smaller O-rings if there are any others).
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  8. Back To Top    #8

    Join Date
    Mar 2010
    Location
    Spring, TX
    Posts
    1,082

    Re: Question about my filter

    Quote Originally Posted by JasonLion
    Yes the entire O-ring (and all of the other smaller O-rings if there are any others).
    When I took it apart that was the only rubber ring that I saw. If the tefelon tape does not work on the plug, what is the next thing to try?

    Thanks again for everyones help.
    13,000 Plaster IG Pool approx
    Hayward C5030 Cart Filter
    Emerson 1081 EB653 1.0 HP 1.40 S.F. 3450 RPM
    Pool Calculator, Pool School, TF Test Kits

  9. Back To Top    #9

    Join Date
    May 2007
    Location
    South Central NJ
    Posts
    3,192

    Re: Question about my filter

    If the o-ring on the drain plug is in good shape, use an old toothbrush on the threads. A couple of counter clockwise wraps of 1/2" or 3/4" white Teflon tape on the plug will help seal any cracks the o-ring may have.

    The 0 to 10 PSI surges indicate an issue at the pump. Is this continuous or does it stabilize at 10 after a couple of minutes? If it doesn't, check the water level and skimmer weir.

    Scott
    Owner of - PoolGuyNJ LLC
    Expert Pool and Spa Repairs, Renovations, and Augmentation. Helping people decide what is the right gear for meeting their needs. Expectations Set, Expectations Met, No Surprises.

  10. Back To Top    #10
    JasonLion's Avatar
    Join Date
    May 2007
    Location
    Silver Spring, MD
    Posts
    37,887

    Re: Question about my filter

    If teflon tape doesn't work, try a non-setting teflon based pipe sealing compound like this one for example. But teflon tape should work.
    19K gal, vinyl, 1/2 HP WhisperFlo pump, 200 sqft cartridge filter, AutoPilot Digital SWG, Dolphin Dynamic cleaning robot
    Creator of PoolMath and Pool Calculator. Other handy links: Support this site, TF Test Kits, Pool School

  11. Back To Top    #11

    Join Date
    Mar 2010
    Location
    Spring, TX
    Posts
    1,082

    Re: Question about my filter

    Quote Originally Posted by PoolGuyNJ
    If the o-ring on the drain plug is in good shape, use an old toothbrush on the threads. A couple of counter clockwise wraps of 1/2" or 3/4" white Teflon tape on the plug will help seal any cracks the o-ring may have.

    The 0 to 10 PSI surges indicate an issue at the pump. Is this continuous or does it stabilize at 10 after a couple of minutes? If it doesn't, check the water level and skimmer weir.

    Scott
    There is no surge on the psi settings. I have neve done a full clean like this time. I have backwashed before and the pressure goes down to a little below 10, around 8 or so and holds steady. I can not tell the exact numbers as it just has little lines, but slightly below 10. It holds steady and then rises as it should as the pump is being used over the course of the month or 2. During the cold months it started a little below 10 and took about 3 months and then it was almost to the halfway point between 10 and 20. Now that I took it apart and did a full clean and put it all back together the pressure came down to half way betweeen 0 and 10 and is holding steady.

    Also the drain plug is this something that has to be bought online or can it be bought at your local pool store?

    Also another question that is about a different topic. The part that is used to fill the pool if need be, it is about 1/4 inches wide, it has a steady flow of water coming out. Is this an issue or is this normal? Hopefully this last question made sense.
    13,000 Plaster IG Pool approx
    Hayward C5030 Cart Filter
    Emerson 1081 EB653 1.0 HP 1.40 S.F. 3450 RPM
    Pool Calculator, Pool School, TF Test Kits

  12. Back To Top    #12

    Join Date
    May 2007
    Location
    South Central NJ
    Posts
    3,192

    Re: Question about my filter

    A Hayward pipe plug (1022C) also fits if they don't have the black one but can be a bit of a PITA to get on/off tightly/easily. Be sure the treads on the filter are clean! make life so much easier.

    Scott
    Owner of - PoolGuyNJ LLC
    Expert Pool and Spa Repairs, Renovations, and Augmentation. Helping people decide what is the right gear for meeting their needs. Expectations Set, Expectations Met, No Surprises.

  13. Back To Top    #13

    Join Date
    Mar 2010
    Location
    Spring, TX
    Posts
    1,082

    Re: Question about my filter

    Quote Originally Posted by PoolGuyNJ
    A Hayward pipe plug (1022C) also fits if they don't have the black one but can be a bit of a PITA to get on/off tightly/easily. Be sure the treads on the filter are clean! make life so much easier.

    Scott
    The one that is was on there right now was hard to get off. I did not have much room to work with since the plug is on the back and there is maybe a foot of room between the wall and pump. So getting something to get it off was hard enough.
    13,000 Plaster IG Pool approx
    Hayward C5030 Cart Filter
    Emerson 1081 EB653 1.0 HP 1.40 S.F. 3450 RPM
    Pool Calculator, Pool School, TF Test Kits

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •