Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 12 of 12

Thread: Spa Jets "Leaking" at sides (not just shooting out the nozzle)

  1. Back To Top    #1
    thephatp's Avatar
    Join Date
    Jul 2018
    Location
    Austin, TX
    Posts
    6

    Spa Jets "Leaking" at sides (not just shooting out the nozzle)

    I just had a pool installed and fired up the heater and used the spa for the first time yesterday. I was very disappointed to find that water/air (from the blower) was "leaking" out the edges of the jet, not just through the nozzle. Is this normal? I would imagine this affects the pressure coming out of the nozzle (especially when it's happening on all 10 of my jets), but not only that, it's causing bubbles to shoot straight up my back, but in an unpleasant way.

    Here's a video with just the pump (and heater) on: Pool Spa - No Air Blower - YouTube

    And here's a video with the pump and air blower (and heater) on: Pool Spa - Air Blower shows leak ?? - YouTube

    Can anyone tell me if this is normal or not? And if not, how do you fix it?

    The pool is a Gunite pool with PebbleSheen plaster. The jets themselves were installed after the pool and spa were filled with water (I was surprised to see that, as I thought they installed them prior to filling with water). How do they ensure a solid seal when installing in water?

    Sorry if these are dumb questions, but I'm a new pool owner and don't know any better.

  2. Back To Top    #2
    Mod Squad mknauss's Avatar
    Join Date
    May 2014
    Location
    Laughlin, NV
    Posts
    11,793

    Re: Spa Jets "Leaking" at sides (not just shooting out the nozzle)

    Welcome to the forum!

    The jets are not installed properly. Call your pool builder and have them return and fix them. It does not matter that they were installed after the spa was filled. They appear to just not be screwed in correctly.

    Please add a signature. Read Pool School - Read This BEFORE You Post
    Information in your signature will show up each time you post and it makes advice more accurate as we know what equipment we are dealing with.

    I suggest you read Pool School - ABCs of Pool Water Chemistry and consider reviewing the entire Trouble Free Pool School book.
    6000 Gallon IG Fiberglass with integrated Spa;Pentair CCP240 Cartridge Filter with Pentair Intelliflo VS Pump and HTR250 heater. IC40 SWG. EasyTouch 4. Dolphin Active20 Robot "Roadrunner", TF 100 Test Kit w/SpeedStir!
    CLICK HERE to Become a TroubleFreePool.com Supporter!! Pool Math App
    Marty

  3. Back To Top    #3
    thephatp's Avatar
    Join Date
    Jul 2018
    Location
    Austin, TX
    Posts
    6

    Re: Spa Jets "Leaking" at sides (not just shooting out the nozzle)

    Will do, thanks @mknauss!

  4. Back To Top    #4
    thephatp's Avatar
    Join Date
    Jul 2018
    Location
    Austin, TX
    Posts
    6

    Re: Spa Jets "Leaking" at sides (not just shooting out the nozzle)

    And for the record (and now in my signature): 19,000 Gallon IG Pool & 500 Gallon IG Spa with PebbleSheen (Blue Granite) plaster; Pentair Intelliflo VS Pump w/ Pentair Cartridge Filter and Pentair Mastertemp 400 heater; Pentair WhisperFlo & Air Blower. EasyTouch 8. <Robotic Vacuum TBD>. Built Aug-Nov 2018.
    19k gal IG Pool & 500 gal IG Spa w/ PebbleSheen (Blue Granite) plaster; Pentair Intelliflo VS Pump w/ Pentair Cartridge Filter and Pentair Mastertemp 400 heater; Pentair WhisperFlo & Air Blower. EasyTouch 8. <Robotic Vacuum TBD>. Built Aug-Nov 2018.

  5. Back To Top    #5
    thephatp's Avatar
    Join Date
    Jul 2018
    Location
    Austin, TX
    Posts
    6

    Re: Spa Jets "Leaking" at sides (not just shooting out the nozzle)

    Quote Originally Posted by mknauss View Post
    Welcome to the forum!
    The jets are not installed properly. Call your pool builder and have them return and fix them. It does not matter that they were installed after the spa was filled. They appear to just not be screwed in correctly.
    The project manager came back out today and drained the spa and took several of the jets off and said they looked fine. (They are Waterway Thread-In jets, FYI.) He screwed them back in and said if I still had problems, he would send his plumber out. That definitely did not fix the problem at all, so I'm concerned there is something wrong with the plumbing.

    Have you seen this problem before? Has anyone else experienced this problem before? Know if it was an easy fix or not? I feel quite frustrated that this is a new build and none of the jets seem to work correctly.
    19k gal IG Pool & 500 gal IG Spa w/ PebbleSheen (Blue Granite) plaster; Pentair Intelliflo VS Pump w/ Pentair Cartridge Filter and Pentair Mastertemp 400 heater; Pentair WhisperFlo & Air Blower. EasyTouch 8. <Robotic Vacuum TBD>. Built Aug-Nov 2018.

  6. Back To Top    #6
    Mod Squad mknauss's Avatar
    Join Date
    May 2014
    Location
    Laughlin, NV
    Posts
    11,793

    Re: Spa Jets "Leaking" at sides (not just shooting out the nozzle)

    Did the project manager see the issue before draining the spa? That is not normal. Have them send the plumber.
    6000 Gallon IG Fiberglass with integrated Spa;Pentair CCP240 Cartridge Filter with Pentair Intelliflo VS Pump and HTR250 heater. IC40 SWG. EasyTouch 4. Dolphin Active20 Robot "Roadrunner", TF 100 Test Kit w/SpeedStir!
    CLICK HERE to Become a TroubleFreePool.com Supporter!! Pool Math App
    Marty

  7. Back To Top    #7
    thephatp's Avatar
    Join Date
    Jul 2018
    Location
    Austin, TX
    Posts
    6

    Re: Spa Jets "Leaking" at sides (not just shooting out the nozzle)

    Quote Originally Posted by mknauss View Post
    Did the project manager see the issue before draining the spa? That is not normal. Have them send the plumber.
    I showed him the video, but he didn't say "oh yeah, it shouldn't be doing that." He basically said "the jets shouldn't be a problem; they probably just need to be tightened." That didn't seem to make much sense to me, but I figured I'd let him try. I emailed him to tell him it still didn't fix the problem, so I'm sure he'll send them out. The reason I'm concerned is because of something my wife mentioned. She was home when they first installed the jets after pool start-up. She said whoever it was spent a lot of time looking and talking and not doing much work. In her opinion, they looked like they didn't know what they were doing. So, I'm not particularly confident that they'll fix anything.

    I'll try not to worry, and I'll report back once I hear something. Thanks for the advice, and for confirming this is not normal!
    19k gal IG Pool & 500 gal IG Spa w/ PebbleSheen (Blue Granite) plaster; Pentair Intelliflo VS Pump w/ Pentair Cartridge Filter and Pentair Mastertemp 400 heater; Pentair WhisperFlo & Air Blower. EasyTouch 8. <Robotic Vacuum TBD>. Built Aug-Nov 2018.

  8. Back To Top    #8
    riley00dog's Avatar
    Join Date
    Nov 2017
    Location
    Brisbane, Qld, Australia
    Posts
    2,185

    Re: Spa Jets "Leaking" at sides (not just shooting out the nozzle)

    Do they screw in or push in? The returns in our pool just push in and the those installed by the Pb would push out of the wall and hang there. He sent the plumber who instead of replacing them, taped them with duct tape it did work but I ended up replacing all 5 of them myself and got a very tight fit and seal. Probably just cheap fittings used originally. Maybe you just need new/different fittings?


    3.2 x 6m | inground concrete | ~27,000 litre | 1.2 - 1.8m | salt and pepper mini pebble | SWCG Atral eq35| Viron xt 1.5 HP VS pump | Astral CA280 sand filter | DB3 robot | 2 x LED lights | travertine coping and paving | ceramic waterline tile |

  9. Back To Top    #9
    thephatp's Avatar
    Join Date
    Jul 2018
    Location
    Austin, TX
    Posts
    6

    Re: Spa Jets "Leaking" at sides (not just shooting out the nozzle)

    Quote Originally Posted by riley00dog View Post
    Do they screw in or push in? The returns in our pool just push in and the those installed by the Pb would push out of the wall and hang there. He sent the plumber who instead of replacing them, taped them with duct tape it did work but I ended up replacing all 5 of them myself and got a very tight fit and seal. Probably just cheap fittings used originally. Maybe you just need new/different fittings?
    They screw in. When you say you replaced them, did you have to replace whatever they push/snap into? What I'm worried about is that they either screwed up the original plumbing pipe, or they screwed up the insert into the pipe (assuming there is one--something for the jet to screw or snap into) and they won't be able to get that out/replace it without messing something up. Hopefully I'm unnecessarily worrying.
    19k gal IG Pool & 500 gal IG Spa w/ PebbleSheen (Blue Granite) plaster; Pentair Intelliflo VS Pump w/ Pentair Cartridge Filter and Pentair Mastertemp 400 heater; Pentair WhisperFlo & Air Blower. EasyTouch 8. <Robotic Vacuum TBD>. Built Aug-Nov 2018.

  10. Back To Top    #10
    riley00dog's Avatar
    Join Date
    Nov 2017
    Location
    Brisbane, Qld, Australia
    Posts
    2,185

    Re: Spa Jets "Leaking" at sides (not just shooting out the nozzle)

    Quote Originally Posted by thephatp View Post
    They screw in. When you say you replaced them, did you have to replace whatever they push/snap into? What I'm worried about is that they either screwed up the original plumbing pipe, or they screwed up the insert into the pipe (assuming there is one--something for the jet to screw or snap into) and they won't be able to get that out/replace it without messing something up. Hopefully I'm unnecessarily worrying.
    Screw in could be a different story depending on which part isnít fitting right. I honestly have no experience with that. Because ours just push into the wall there is no fixture on/in the shell. The housing just pushes into place with minimal effort. It may still be the housing that broken/incorrect so donít panic. Your Pb agrees that it isnít right so will sort it for you one way or another.


    3.2 x 6m | inground concrete | ~27,000 litre | 1.2 - 1.8m | salt and pepper mini pebble | SWCG Atral eq35| Viron xt 1.5 HP VS pump | Astral CA280 sand filter | DB3 robot | 2 x LED lights | travertine coping and paving | ceramic waterline tile |

  11. Back To Top    #11

    TFP Guide

    In the Industry

    Join Date
    Apr 2015
    Location
    tucson, arizona
    Posts
    1,405

    Re: Spa Jets "Leaking" at sides (not just shooting out the nozzle)

    Waterway has a full line of gunite jets. Most all the Jet internals I've seen thread into a niche without any type of seal, It may be that when you turn on the blower there is to much air entering the jet and it runs up the pipe and out the sides of the internal. In the first video you show the jet is operating properly and should need no more air. You can go to the Waterway website and under resources click on instructional manuals and the jets. Your's look like the poly jets and you can see how there installed

  12. Back To Top    #12

    In the Industry

    Join Date
    May 2018
    Location
    Phoenix az
    Posts
    32

    Re: Spa Jets "Leaking" at sides (not just shooting out the nozzle)

    Go to the source call waterway, that is who the builders, installers, and plumbers, etc, are going to call when they have questions and/or concerns.

    I don't see anything wrong with the jets, or the installation of them, everything you could ever want from a jet is shown in the 1st video.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •