Become a TFP Supporter Pool Math Forum Rules Pool School

View Poll Results: Do you still have problems with your Liquidator?

Voters
18. You may not vote on this poll
  • I don't have any problem now

    13 72.22%
  • I have a problem but I can live with it

    2 11.11%
  • I have a problem that cripples my LQ

    1 5.56%
  • Because of the problems I dumped my LQ

    2 11.11%
Results 1 to 13 of 13

Thread: Do you still have problems with your Liquidator?

  1. Back To Top    #1
    Water_man's Avatar
    Join Date
    Jun 2008
    Location
    Brookline, MA
    Posts
    390

    Do you still have problems with your Liquidator?

    Last year we had numerous posts regarding Liquidator problems related to installation, flow, and WS issues. These problems and issues were dealt with by many contributors and many of them seem to have been solved. This year the activity is very low.
    There could be three reasons for this:

    1. The most favorable one: Most or all or the problems can be solved because of the huge body of knowledge collected here since last year.

    2. People gave up and live with their problem.

    3. People just got sick and tired of their LQ and dumped it.

    I wonder, does anybody still have any unsolved problem with his/her LQ which impairs its performance? If you have WS but it doesn't affect the flow or performance then your problem is aesthetic and it doesn't count.
    This is my ticket for Heaven (when all's working..) :
    22k Gal gunite IGP, 38 SF Anthony DE filter, 1 HP Hayward Super Pump
    380k BTU Raypak Natural Gas Heater (Model RP405A) and solar cover
    8 gal Liquidator w/ 12% bleach, Dolphin Diagnostic Advantage robotic cleaner. 3800 ppm salt, 50 ppm borates.

  2. Back To Top    #2
    Mod Squad Bama Rambler's Avatar
    Join Date
    Jun 2009
    Location
    SouthWest Alabama
    Posts
    21,778

    Re: Do you still have problems with your Liquidator?

    Thanks for posting this. I just bought a Liquidator from another member and I feel confident that I can overcome any problems associated with it because of the excellent info I've read about it here. I'll be keeping track of this thread/poll.
    Dave J. TFP Moderator
    24' x 52" Round AGP. 2hp/¼hp SPL Power-Flo 2-speed pump. 200sqft Waterway Cartridge Filter. 45MHP2(3GPD) Stenner Peristaltic Pump
    Pool School ----- Pool Math ----- TF-Test Kit

  3. Back To Top    #3
    Mod Squad JohnT's Avatar
    Join Date
    Apr 2007
    Location
    SW Indiana
    Posts
    8,618

    Re: Do you still have problems with your Liquidator?

    The only way mine could be better is if it went to the store an brought the bleach home itself.
    TFP Moderator
    20K Gallon 20X36 Vinyl Inground
    Hayward S244T Sand Filter with 1HP Whisperflo Pump. Liquidator C-201 and Solar Heat

  4. Back To Top    #4

    Join Date
    Feb 2008
    Location
    Milford, CT
    Posts
    325

    Re: Do you still have problems with your Liquidator?

    The tubing on mine has "whitened over", but it doesnt seem to be causing any flow issues currently.

    I have all the parts ready to go for the upgrade to 3/8" tubing, but like they say "if it aint broke dont fix it". I might wait until next season to upgrade it.
    22K IG vinyl, .5HP Northstar pump, S244T filter, AutoPilot Digital w/SC-48 cell

  5. Back To Top    #5
    Water_man's Avatar
    Join Date
    Jun 2008
    Location
    Brookline, MA
    Posts
    390

    Re: Do you still have problems with your Liquidator?

    Quote Originally Posted by chrisexv6
    The tubing on mine has "whitened over", but it doesnt seem to be causing any flow issues currently.

    Do you see the WS in the flow indicator too? If the WS bothers you, you may add 50 ppm borates and enjoy all the benefits of borates, including most likely WS prevention.

    I have all the parts ready to go for the upgrade to 3/8" tubing, but like they say "if it aint broke dont fix it". I might wait until next season to upgrade it.

    If your flow is adequate there's no reason to change. I switched to 12% bleach so I run to the store half the time and I can use a low flow.
    This is my ticket for Heaven (when all's working..) :
    22k Gal gunite IGP, 38 SF Anthony DE filter, 1 HP Hayward Super Pump
    380k BTU Raypak Natural Gas Heater (Model RP405A) and solar cover
    8 gal Liquidator w/ 12% bleach, Dolphin Diagnostic Advantage robotic cleaner. 3800 ppm salt, 50 ppm borates.

  6. Back To Top    #6
    jwfrank's Avatar
    Join Date
    Oct 2008
    Location
    Todi, Umbria, Italy
    Posts
    55

    Re: Do you still have problems with your Liquidator?

    I love my LQ, installed in June. I started with 50ppm borates this year, use 12% bleach, and have no WS problem. Based on posts, I try to minimize stirring up the "stuff" that seems to collect at bottom of LQ, when I add new bleach. I do this by: suctioning bleach from a 25kg container into the black funnel and using a piece of the plastic tubing to get the flow as low as possible into the funnel. When I clean the LQ after the summer, I will undo the two pieces of the funnel and thread this tubing beyond the clip that holds the two pieces together

    I get a max flow rate of only about 3, but that seems enough to keep my pool at 5-7 ppm FC which is enough for my pool usage and CYA level. (I run the pump about 12 hours on a timer)

    PS:I too was surprised by how few posts there have been this year after flurry of activity last year

  7. Back To Top    #7
    krcossin's Avatar
    Join Date
    May 2007
    Location
    Detroit Burbs
    Posts
    113

    Re: Do you still have problems with your Liquidator?

    I would say the Liquidator has been the best thing I have added to the pool. Very easy to check the level, fill, and adjust the flow.
    Toss out the **** tubing it comes with and upgrade them.
    2007 - 24' AG Doughboy Desert Spring dished 1.5', with DB Power Pak II-1hp pump, DB Sequel I Plus DE, Hayward H-Series Heater 100k + 8gal LQ.

  8. Back To Top    #8
    JoseJones
    Guest

    Re: Do you still have problems with your Liquidator?

    I never actually had any problems other than the install was a bit dicey at moments.

    I haven't dug around the posts, but I use the 12% Cl and it seemed that anyone using lesser % were getting the WS, which was the big complaint.

    Also, since installing the LQ I've had to shock the pool very little. The pool just stays happy all the time!

    Best pool investment so far!

  9. Back To Top    #9

    Join Date
    Aug 2007
    Location
    Austin, TX
    Posts
    341

    Re: Do you still have problems with your Liquidator?

    I love my LQ and pH Adjuster. After two summers and going into it's third winter, no issues to report. During the heat of our summer (68 days of 100 plus days) my LQ couldn't keep up, I had to add an extra jug of chlorine to the pool manually. Not a big deal and not unexpected.
    20k Gunite/Prism Blue-Pebblesheen, Pentair Tagelus TA-100D Sand Filter, Heliocol Solar Water Heater, 2 bubblers and 2 waterfalls installed 2007, 3hp IntelliFlo VS Pump 011018 installed 2013, Aquabot Turbo T4 RC and Stenner 45MHP10 w/The Liquidator container installed 2012.
    Antigua Spa by Artesian Spas: 325 gl, 52 jets, 6 hp 2 sp & 6 hp 1 sp, Circulation System 24 Hour Whisper Pure, Ozonator, LED digital lighting, The Artesian Pillowfall installed 2007.
    Retired: 2hp Pentair Whisperflow, Legend Platinum w/booster pump, PH Adjuster

  10. Back To Top    #10

    Join Date
    Jun 2007
    Location
    SF Bay Area
    Posts
    441

    Re: Do you still have problems with your Liquidator?

    Sabot,

    How often did you have to add the extra chlorine? Daily? Weekly?
    24,000 gallon inground freeform pool/spa circa 1983 (113 ft perimeter, 625 sq ft) with 350 gallon attached spill-over spa
    2007 2 HP, three-phase Hayward TriStar pump which is powered by an Ikeric VS-200 variable speed drive system
    1983 Laars XE Pool/Spa Heater Type ES 400,000 BTU, 1998 Hayward Super Star-Clear C-4000 cartridge filter (400 sq ft, 4 separate cartridges)
    1998 Polaris 380 pressure-side cleaner w/ 3/4 HP booster pump
    One skimmer :( and one PoolSkim :), One Supervision Galaxy LED pool lamp, Second story solar panels
    Hayward/GoldLine AquaLogic PS4 (replaced 1983 vintage dual circuit Intermatic timer)

  11. Back To Top    #11

    Join Date
    Aug 2007
    Location
    Austin, TX
    Posts
    341

    Re: Do you still have problems with your Liquidator?

    1 jug a week.
    20k Gunite/Prism Blue-Pebblesheen, Pentair Tagelus TA-100D Sand Filter, Heliocol Solar Water Heater, 2 bubblers and 2 waterfalls installed 2007, 3hp IntelliFlo VS Pump 011018 installed 2013, Aquabot Turbo T4 RC and Stenner 45MHP10 w/The Liquidator container installed 2012.
    Antigua Spa by Artesian Spas: 325 gl, 52 jets, 6 hp 2 sp & 6 hp 1 sp, Circulation System 24 Hour Whisper Pure, Ozonator, LED digital lighting, The Artesian Pillowfall installed 2007.
    Retired: 2hp Pentair Whisperflow, Legend Platinum w/booster pump, PH Adjuster

  12. Back To Top    #12
    Water_man's Avatar
    Join Date
    Jun 2008
    Location
    Brookline, MA
    Posts
    390

    Re: Do you still have problems with your Liquidator?

    Quote Originally Posted by Sabot
    During the heat of our summer (68 days of 100 plus days) my LQ couldn't keep up, I had to add an extra jug of chlorine to the pool manually. Not a big deal and not unexpected.
    Do you get max flow out of your LQ? If you've used 6% bleach, converting to 12% can solve this minor problem.
    This is my ticket for Heaven (when all's working..) :
    22k Gal gunite IGP, 38 SF Anthony DE filter, 1 HP Hayward Super Pump
    380k BTU Raypak Natural Gas Heater (Model RP405A) and solar cover
    8 gal Liquidator w/ 12% bleach, Dolphin Diagnostic Advantage robotic cleaner. 3800 ppm salt, 50 ppm borates.

  13. Back To Top    #13

    Join Date
    Aug 2007
    Location
    Austin, TX
    Posts
    341

    Re: Do you still have problems with your Liquidator?

    I have not looked for a 12% dealer. I buy mine from Sams at $8.12 per case of three jugs of 6%. I understand what the LQ can do and can't, no big deal to help it out for two months. It works perfect for the other 10 months. I run it maxed out during the summer then dial it back during the off season.
    20k Gunite/Prism Blue-Pebblesheen, Pentair Tagelus TA-100D Sand Filter, Heliocol Solar Water Heater, 2 bubblers and 2 waterfalls installed 2007, 3hp IntelliFlo VS Pump 011018 installed 2013, Aquabot Turbo T4 RC and Stenner 45MHP10 w/The Liquidator container installed 2012.
    Antigua Spa by Artesian Spas: 325 gl, 52 jets, 6 hp 2 sp & 6 hp 1 sp, Circulation System 24 Hour Whisper Pure, Ozonator, LED digital lighting, The Artesian Pillowfall installed 2007.
    Retired: 2hp Pentair Whisperflow, Legend Platinum w/booster pump, PH Adjuster

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •