Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Troubleshooting my Pump

  1. Back To Top    #1
    rileypool's Avatar
    Join Date
    Mar 2009
    Location
    High Desert, California
    Posts
    5

    Troubleshooting my Pump

    What are the reasons a pump will not prime and suck water through? Mine is stuck. The pump is brand new. We replaced it after the old one got fried. If the new pump is installed and wont fill with water, what can I do to get things cleared and/or the pump suction going again? Thanks in advance.
    46k gallon vinyl, Intelliflo VF, Quad DE 100, Autopilot DIG60, Raypak R405a, Bravo Fury Auto Cleaner

  2. Back To Top    #2

    Join Date
    Mar 2009
    Location
    Glendora, California
    Posts
    169

    Re: Troubleshooting my Pump

    Are you priming the pump? If not, remove the cover of the pumps basket and fill it with water. You may not be able to fill it all the way up. If not that's OK, just keep putting water until the level no longer rises, replace the cover and then turn it on. Once running, make sure to bleed the filter of any air.
    18k Inground Plaster pool / TriStar Variable Speed Pump and Controller
    48sq ft Hayward DE filter/ Swim pure Plus 40k cell / Kreepy Krauly
    Solaxx Ph-Tek

  3. Back To Top    #3

    In the Industry

    Join Date
    Aug 2007
    Location
    near the swamp
    Posts
    802

    Re: Troubleshooting my Pump

    Check the oring around the pump lid.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •