Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Hayward Aquarite Goldline main circuit board replaced. No power light

  1. Back To Top    #1

    Hayward Aquarite Goldline main circuit board replaced. No power light

    My apologies if this has been asked somewhere among the plethora of threads. I have an older Hayward Aqua Rite Goldline salt water generating unit. After replacing the current limiter a few times I decided to finally buy a replacement board which I swapped out this evening. Before I swapped out the board the only light that I could not get to come on was the power light hence my reasoning to purchase a replacement board. I did not purchase the little display board though.

    Anyways after replacing the board and getting everything hooked back up and turning on the unit on auto I do get a generating light eventually after my no flow light goes out and I can also get super chlorinating light to come on as well, however my power light Still Remains out. So I'm stumped. I am going to clean my T15 cell since its been a while to see if that's the culprit.

    I am here for any other suggestions please.

  2. Back To Top    #2

    Re: Hayward Aquarite Goldline main circuit board replaced. No power light

    What are the diagnostic readings?
    Support the site

    Trouble Free Pool is a free resource. The people who answer questions are volunteers. If you find the site to be a good resource, please consider making a donation to help support the site. Thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •