Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: pool machine broke?

  1. Back To Top    #1

    Join Date
    Mar 2018
    Location
    florida
    Posts
    1

    pool machine broke?

    hi I recently replaced my pressure release valve for my polaris and when I turn my system on the water still bursts out of the valve instead of going to the polaris, I tried detaching parts of the cable leading to my polaris to see if a certian section might be blocked but I got all the way up to the filter and it still bursts out. Our filter that is connected to the cable was at first full of sand so we replaced the filter too and that didnt work either, what might be wrong?

  2. Back To Top    #2
    sktn77a's Avatar
    Join Date
    May 2010
    Location
    Chapel Hill, NC
    Posts
    736

    Re: pool machine broke?

    Are you screwing the release valve all the way in so that you can't see any of the pressure release hole? Do you have the red or blue flow restrictor in the new valve body? Did you check the flow to the polaris and the wheel speed?

    Edit: Forgot to mention that the auto reverse valve might be blocked/stuck.
    Keith
    15,000 gallon in-ground gunite/plaster pool, 1.5" PVC plumbing
    1.0HP Sta-Rite DuraGlass P2R pump, Hayward S244T sand filter
    Teledyne-Laars Lite-2 250k heater, Hayward CL200 chlorinator
    Polaris 380/Hayward 6060 booster pump

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •