Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: Pentair Great White gets stuck on main drain

  1. Back To Top    #1

    Join Date
    Jun 2009
    Location
    Jax, FL
    Posts
    21

    Pentair Great White gets stuck on main drain

    Does anyone have any experience with this pool cleaner? Our pool was completed last month and the cleaner worked great in the beginning. Recently the darn thing keeps getting stuck on one of the main drains and doesn't move. I've got to manually push it away from this one drain but eventually it will get back down in the same area and get stuck again. Can someone give me some advice on how to fix this problem?
    23K gal IG pool, Crystal Stone finish, 2.0HP Pentair Whisperflow pump, 200 sq. ft cartridge filter, Intellichlor SWG, Ultra Pure Ozinator, AquaCal H120 heat pump, Pentair Great White cleaner

  2. Back To Top    #2

    In the Industry

    Join Date
    Aug 2007
    Location
    near the swamp
    Posts
    802

    Re: Pentair Great White gets stuck on main drain

    Have you tried turning the drain off via valve near the ground by the pump?

  3. Back To Top    #3

    Join Date
    May 2014
    Location
    Tampa
    Posts
    50

    Re: Pentair Great White gets stuck on main drain

    I am having the same issue recently. It never did it before.

    I have tried completely turning off the main drain but it does not help.

    Also verified the brush is actuating every minute or so.

    I watch it move slightly but just won't break away from drain.

    What could have changed to cause this? Surely my brush height couldn't have been reduced over a single season.

    Sent from my GS3 on Cyanogenmod with the older / better version of Tapatalk!
    22,000 rectangular plaster. Hayward everything on a C1750 cartridge filter and a Liquidator.

  4. Back To Top    #4

    Join Date
    May 2014
    Location
    Tampa
    Posts
    50

    Re: Pentair Great White gets stuck on main drain

    The idler gears and cam gear were worn causing the cam to not fully rotate.

    Sent from my GS3 on Cyanogenmod with the older / better version of Tapatalk!
    22,000 rectangular plaster. Hayward everything on a C1750 cartridge filter and a Liquidator.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •