Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 5 of 5

Thread: Pump Loses Prime

  1. Back To Top    #1
    chris732003's Avatar
    Join Date
    Jun 2009
    Location
    Baton Rouge, La.
    Posts
    2

    Pump Loses Prime

    Pentair Sand Filter
    3/4 Hp Pump
    IG Fiberglass
    20,000g

    Trying to vacum up dead algae. Vacum through skimmer w/ basket. Pump loses prime in every 2 min. Thinking something is clogged, placed garden hose in line to try to free debris. Didnt work any suggestions on how to free clog from skimmer to pump. (Dis. 20')

  2. Back To Top    #2

    Join Date
    Mar 2009
    Location
    Glendora, California
    Posts
    169

    Re: Pump Loses Prime

    Does the pump still lose prime if you run it without the vacum attached?
    18k Inground Plaster pool / TriStar Variable Speed Pump and Controller
    48sq ft Hayward DE filter/ Swim pure Plus 40k cell / Kreepy Krauly
    Solaxx Ph-Tek

  3. Back To Top    #3
    chris732003's Avatar
    Join Date
    Jun 2009
    Location
    Baton Rouge, La.
    Posts
    2

    Re: Pump Loses Prime

    No it doesnt but the basket does take a while to fill up.

  4. Back To Top    #4

    Join Date
    Mar 2009
    Location
    Glendora, California
    Posts
    169

    Re: Pump Loses Prime

    I doubt this is your problem but it wouldn't hurt to check. Some pump skimmers have drain plugs. You may want to see if yours does and if so make sure it is snug and the O ring is in good condition.

    To check your intake line, you can try and run a snake through it and see if it gets hung up along the way just to be sure it is clogged.
    18k Inground Plaster pool / TriStar Variable Speed Pump and Controller
    48sq ft Hayward DE filter/ Swim pure Plus 40k cell / Kreepy Krauly
    Solaxx Ph-Tek

  5. Back To Top    #5

    Join Date
    Mar 2007
    Location
    Coastalish 'down easter'
    Posts
    4,160

    Re: Pump Loses Prime

    Welcome to TFP!!

    A clog may be the issue but an easier thing to check is the connections on the vacuum hose. Often one cuff will swivel if you try to turn it, the other will not - you want the end that swivels on the vac head, the swivel on it will draw air and kill the prime if attached to the skimmer plate

    Switch the vac hose around and see if the problem disappears 8)

    Also, do you prime the hose first? If not - you have to
    Luv& Luk
    -Ted

    Having done construction and service for 4 pool companies in 4 states starting in 1988, what I know about pools could fill a couple of books - what I don't know could fill a couple of libraries :-D

    POOL SCHOOL, TF Testkits, Jason's Pool Calculator, CYA vs. cl chart, (Just a few DARNED handy links!)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •