Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 4 of 4

Thread: need help with filter install leaking

  1. Back To Top    #1

    Join Date
    May 2009
    Location
    Ontario, Canada
    Posts
    84

    need help with filter install leaking

    We hooked our pump and filter up today on our new pool.

    As the water reached the skimmer, (haven't turned on pump yet) water was coming out of waste, which I was expecting but water is also leaking out of the C-clamps that hold all the housing on top of the filter.

    I took it apart again. wipe the O-ring off and wiped the inside where the O-ring lay. My husband used vaseline....(yikes...is that bad?)Put it all back together....c- clamps really tight....and still leaking....argh

    do you think the O-ring is still the issue? Is there anything else I should check?
    21' 54" Round AG, 10K gallons,1HP 2 speed pump, Sand filter 200lb
    Have had a sparkling BBB pool all summer....

  2. Back To Top    #2

    Join Date
    Mar 2009
    Location
    Glendora, California
    Posts
    169

    Re: need help with filter install leaking

    There was a post about using vaseline earlier this week and the replies were, that it is bad to use. Someone who had experience with vaseline said it will harden and ruin the O rings, where the silicone lubricant keeps the O rings like new. Not sure if one time is enough to ruin it though.
    18k Inground Plaster pool / TriStar Variable Speed Pump and Controller
    48sq ft Hayward DE filter/ Swim pure Plus 40k cell / Kreepy Krauly
    Solaxx Ph-Tek

  3. Back To Top    #3

    Re: need help with filter install leaking

    Once the clamp is on the filter, use a rubber mallet every so often as your tightening it down to tap around the clamp. It makes a big difference.
    Intex 15' x 36" Easy Set Pool
    Intex 2500 gal/hr pump/filter
    Sunheater 2' x 20' Solar heater
    TF - 100 Test Kit

  4. Back To Top    #4

    Join Date
    May 2009
    Location
    Ontario, Canada
    Posts
    84

    Re: need help with filter install leaking

    thanks all

    It turns out we put the o-ring in the wrong place. We had put the O-ring on the filter opening and put the housing on top....not realizing it belonged on the housing which then got lowered onto the filter.

    This whole pool install was waaaaaaaaaaay beyond us....but we seem to have worked our way through it.
    21' 54" Round AG, 10K gallons,1HP 2 speed pump, Sand filter 200lb
    Have had a sparkling BBB pool all summer....

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •