Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 5 of 5

Thread: Used Savannah - no manual - Error Messages!

  1. Back To Top    #1

    Used Savannah - no manual - Error Messages!

    Manufacturer "Savannah Spas"; bought out by "Maxx"
    Model: Excalibur Serial #: 1552
    Manufacture date: Jan 17, 1997
    Digital spa controls: Brett Aqualine (Brett line BL-70)
    PWA 34-5007
    Other serial #BA96208-036

    2 pumps, both 230 Volts
    40 Amps
    Gal per min 85

    We're getting error messages E 2 and E 3 but don't know what they mean without the manual!
    very plain 1966 Rectangle, refiberglassed in distant past, 15K gall, Pentair 320 Cartridge filter
    Dolphin Diagnostics cleaner (the best!)

  2. Back To Top    #2
    spishex's Avatar
    Join Date
    Oct 2008
    Location
    Hillsborough, NC
    Posts
    1,375

    Re: Used Savannah - no manual - Error Messages!

    Those are both high limit errors, though it's strange that you'd get both at the same time since they're opposites (E2 = shorted, E3 = open). Try turning off the tub, disconnecting the high limit, and turning it back on again and check to see what errors you still get.

  3. Back To Top    #3

    Re: Used Savannah - no manual - Error Messages!

    Thanks for the reply, now more questions!

    I am no longer getting the E2 error message since I discovered that the 220 volt circulating pump was only tied into 110 volts. I now get E3 error and there is no power to the heater element even though the heat light is on. The Jet2 light is on and the jet pump runs continuously and only turns off momentarily when you press the button. If I hook the jet pump into the Jet1 outlet, nothing happens.
    very plain 1966 Rectangle, refiberglassed in distant past, 15K gall, Pentair 320 Cartridge filter
    Dolphin Diagnostics cleaner (the best!)

  4. Back To Top    #4
    spishex's Avatar
    Join Date
    Oct 2008
    Location
    Hillsborough, NC
    Posts
    1,375

    Re: Used Savannah - no manual - Error Messages!

    The E3 error prevents the heater from coming on. The Jets may be on because of some sort of freeze protection programming (if this had happened during the winter the tub would want to keep the water moving if the heater wasn't working). I'd try replacing the high limit.

  5. Back To Top    #5

    Re: Used Savannah - no manual - Error Messages!

    We had the tech out this am and he replaced the high limit sensor and it now works. Many Thanks for your help!!
    very plain 1966 Rectangle, refiberglassed in distant past, 15K gall, Pentair 320 Cartridge filter
    Dolphin Diagnostics cleaner (the best!)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •