Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 6 of 6

Thread: Filter PSI is at O

  1. Back To Top    #1

    Join Date
    Jan 2017
    Location
    PALM BEACH GARDENS, FL
    Posts
    107

    Filter PSI is at O

    My pool is clean all seems to be good, I clean my filters out at least once a month. I just noticed that the PSI is at 0 on my filter gauge. I think it has always been there but not sure, it is now.
    I also notice sometimes in my pump skimmer basket i dont always have water all the way to the top clear lid.

    So, do I need to have water all the way to the top, when i acheive this, will I have PSI on the filter gauge.

    thanks
    GTP
    Pool Size: 17,504 gallons.
    In ground gunnite plaster pool (Florida Gem Stucco)
    Filter Hayward Cartridge C200SHayward Ecostar SP3400VSP variable speed pump.
    Pool Install December 2016 Blue Essence SALT system
    (2) 48" Sheer Descent Waterfalls and (1) bubbler on small deck

  2. Back To Top    #2

    Join Date
    Jan 2017
    Location
    PALM BEACH GARDENS, FL
    Posts
    107

    Re: Filter PSI is at O

    Update: I now have water all the way to the top of the skimmer at the pump (clear lid) and I up the pump speed a bit, but still only about 3 PSI at filter gauge
    Pool Size: 17,504 gallons.
    In ground gunnite plaster pool (Florida Gem Stucco)
    Filter Hayward Cartridge C200SHayward Ecostar SP3400VSP variable speed pump.
    Pool Install December 2016 Blue Essence SALT system
    (2) 48" Sheer Descent Waterfalls and (1) bubbler on small deck

  3. Back To Top    #3

    Re: Filter PSI is at O

    What speed are you using?

    How high is the pressure gauge above the pool water surface?
    Support the site

    Trouble Free Pool is a free resource. The people who answer questions are volunteers. If you find the site to be a good resource, please consider making a donation to help support the site. Thanks.

  4. Back To Top    #4
    Mod Squad Jimrahbe's Avatar
    Join Date
    Jul 2014
    Location
    Bedford, TX
    Posts
    9,246

    Re: Filter PSI is at O

    GTP,

    I run at 1,200 RPM most of the time so that my SWCG will work.. At that speed, my filter PSI is about 2 and I have just a few bubbles in the pump lid.

    This is perfectly normal...

    Thanks,

    Jim R.
    Finished in 2015 - 17K Gal, IG, 20' x 25' Almost Rectangular Pool, Pebble finish, three rockport water falls. Pentair Equipment: EasyTouch 4, IC40 SWG, 3 HP VS Pump, CCP520 Cartridge Filter.
    TF100 with SpeedStir and SampleSizer, ColorQ Pro 7, Dolphin Premier Robot Cleaner, added Screen Logic 2, added small 3 person Caldera Spa.

  5. Back To Top    #5

    Join Date
    Jan 2017
    Location
    PALM BEACH GARDENS, FL
    Posts
    107

    Re: Filter PSI is at O

    I run about 1600 RPM. My gauge is about 4 feet above pool grade
    Pool Size: 17,504 gallons.
    In ground gunnite plaster pool (Florida Gem Stucco)
    Filter Hayward Cartridge C200SHayward Ecostar SP3400VSP variable speed pump.
    Pool Install December 2016 Blue Essence SALT system
    (2) 48" Sheer Descent Waterfalls and (1) bubbler on small deck

  6. Back To Top    #6
    mas985's Avatar
    Join Date
    May 2007
    Location
    Pleasanton, CA
    Posts
    11,983

    Re: Filter PSI is at O

    Quote Originally Posted by GreenTerrorPool View Post
    I run about 1600 RPM. My gauge is about 4 feet above pool grade
    Low RPM = Low PSI. Higher filter height = even lower PSI. So normal for your situation.
    Mark
    Hydraulics 101; Pump Ed 101; Pump/Pool Spreadsheets; Pump Run Time Study; DIY Acid Dosing; DIY Cover Roller
    18'x36' 20k plaster, MaxFlo SP2303VSP, Aqualogic PS8 SWCG, 420 sq-ft Cartridge, Solar, 6 jet spa, 1 HP jet pump, 400k BTU NG Heater

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •