Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Dolphin Triton and PowerSupply 9995675 - Shuts off after 5-10mins.

  1. Back To Top    #1

    Join Date
    May 2017
    Location
    WILMINGTON, ma
    Posts
    2

    Dolphin Triton and PowerSupply 9995675 - Shuts off after 5-10mins.

    I bought a 2-3 year old unit. Whether the robot is attached or not attached to the powersupply it seems to power off after 5-10mins no matter what.

    Has anyone had this problem? Power supply?

  2. Back To Top    #2

    Re: Dolphin Triton and PowerSupply 9995675 - Shuts off after 5-10mins.

    Quote Originally Posted by vcolella View Post
    I bought a 2-3 year old unit. Whether the robot is attached or not attached to the powersupply it seems to power off after 5-10mins no matter what.

    Has anyone had this problem? Power supply?
    You bought a 2-3 year old used unit? Has this been happening since you bought it?
    Geebot
    Chicago, IL
    30K gal, InGround Plaster Finish, 3.5'-9.5', Maytronics S300 Cleaner

  3. Back To Top    #3

    Join Date
    May 2017
    Location
    WILMINGTON, ma
    Posts
    2

    Re: Dolphin Triton and PowerSupply 9995675 - Shuts off after 5-10mins.

    Yeah .. it was used. I confirmed that the PS was the problem and had to buy a new one. Not sure why the other one would just shut off after 15mins but they are sealed so difficult to open it up to check it out. Maybe there is a fix for it - dunno.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •