Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Zodiac MX8 parts replaced and still not spinning

  1. Back To Top    #1

    Join Date
    May 2017
    Location
    Clearwater/FL
    Posts
    1

    Zodiac MX8 parts replaced and still not spinning

    Hello all, my first post here. I tried searching but there's so much content about these that it's hard to sift through the obvious to find my unique situation.

    I've had my MX8 for a couple years and either last year or this year I've replaced:
    • engine (May '17)
    • Unicel C-8409 Replacement Filter Cartridge (Mar '17)
    • tracks (Feb '17)
    • Side B direction control device (Aug '16)
    • Side A (Apr '16)


    Some time at the end of last year or beginning this year I've removed the flow regulator at the skimmer and I don't recall why, but the vacuum operated fine until about April. Now it has plenty of suction (cartridge housing reads 12-13 PSI) and if I manually spin the fins it'll rotate a few times but stop.

    When I put in the flow gauge it's maxed out without the flow regulator. I've tried reinstalling the flow regulator and adjusted to the 2-4 position on the flow gauge and same behavior.

    I don't want to purchase a new one to find out that wasn't the problem. Also don't want to purchase a new one when it was just a part needed.

    When I remove it from the pool and tinker, all parts seem to move freely, but I don't have a new one on hand for comparison.

    Any troubleshooting suggestions?

    TIA
    My pool:
    In-ground, 1970 construction. Hayward II Super Pump, installed 2016. Zodiac MX8 suction side vacuum, purchased 2014.

  2. Back To Top    #2

    Join Date
    Apr 2016
    Location
    Riverview, FL
    Posts
    351

    Re: Zodiac MX8 parts replaced and still not spinning

    I had similar problem with my MX6. I took my unit apart and did a through cleaning of the unit finding some fine sand particles in the Sides and wheels. Guessing the fine particles were just enough to cause problems based on suction but didn't create enough resistance when turning by hand as after cleaning the vacuum is working great again. lso, you might want to check out this video at the 2:25 mark. It gives a suggestion on adding a washer to get a better fit with the gearing to fit tighter.
    Free Form 13K IG (Quartz) w/Screen Enclosure - 2 Sheer Descents, 1 Bubbler - Hayward 60 SF DE Sta-Rite - Hayward SP3400VSP EcoStar - Hayward Aqua Rite AQR9 (T-Cell-9) SWG - Zodiac MX6 - July 2016 - Taylor K-2006 - Taylor K-1766 Salt Test

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •