Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: 2 of 4 return jets not working properly- no or low water volume +lots of air

  1. Back To Top    #1

    Join Date
    May 2017
    Location
    Esterillos Oeste, Costa Rica
    Posts
    1

    2 of 4 return jets not working properly- no or low water volume +lots of air

    Return jets 3 & 4 at top skimmer end of pool do not push any water when all 4 return jet's valves turned full open. Jets 1 & 2 have lots of volume. I turned down volume for jets 1 & 2 to low, this got jets 3 & 4 to pump some volume of water. Total water volume being pushed by all 4 is not very high with these valve setting. Jets 1 & 2 still pushing more water. Jets 3 & 4 have lots of air coming out. This issue has gotten worse over the last few weeks and now no water out of Jets 3 & 4 when all jets turned full on.
    I turned off jets 1 &2 that work well. Jets 3 & 4 then work pretty good but again lots of air. Let it run this way a while and air bubbles got better over a few minutes but still air. I have turned down valves for jets 1 & 2 in order to get 3 & 4 working somewhat. Will leave it this way for a while.
    Suggestions for getting back to full functionality are definitely welcome.

    To further complicate the above issue, my pump impeller is going out as very high pitch metallic whine. Pump is 8-9 years old so I elected to have a friend bring down a new motor and upgrade kit that includes improved impeller, seals, and diffuser. Will change all that out in early June. Pool parts in Costa Rica are ridiculously expensive esp. motors.

    Thanks very much for your help. I can certainly use it as my pool shop is pretty inept.

    Wink
    13' x 23' IGP, Concete construction, all tile
    4.3' deep- 9617 gallons
    Hayward 1/2 HP pump, sand filter, 4 returns, drain & skimmer

  2. Back To Top    #2
    Richard320's Avatar
    Join Date
    Jan 2010
    Location
    San Dimas, CA (LA County)
    Posts
    20,299

    Re: 2 of 4 return jets not working properly- no or low water volume +lots of air

    My gut says there's a low flow problem from a bad impeller and maybe a clogged filter, too. With both happening, you might not see the filter pressure climb, but you have noticed the reduced flow.

    Wait until the pump is fixed and do a backwash then. If you still have problems, then worry.
    16K freeform gunite with spa; Pentair 4000 DE filter; Century Whisperflow 1 HP; Pentair Minimax heater.
    Troublefree does not mean Maintenancefree. It's like brushing your teeth: You can spend a couple minutes a day and pennies a week or go to the dentist once a year and spend several thousand dollars.
    A pool is like a pet - you have to feed it every day, even the days you don't want to play with it!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •