Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 6 of 6

Thread: Spa Jet Problems after Refinish

  1. Back To Top    #1

    Join Date
    Apr 2017
    Location
    Orlando
    Posts
    3

    Spa Jet Problems after Refinish

    I had my pool resurfaced a few weeks ago, and recently noticed that I have a problem with the return jets in my spa.

    To the best of my recollection, the six jets are plumbed in two (2) banks of (3)...in two 'loops', again, if I am remembering correctly...the pool is 19 years old.

    The refinish company replaced all return fittings in the pool, which I was not expecting, but thought was nice. However, now the middle jet in each bank will not generate pressure. These would be jets 2 and 5 if looking at the six jets in order in the spa. They replaced the fittings with basic 1" Hayward eyeball type fittings. I thought replacing them all with 3/4" fittings would solve the problem, but it did not. I know when the pool was new, that the fittings were the ones with the blue rubber nozzles protruding from them. The rubber had long since disintegrated, and I didn't miss it, and that's why I didn't question the contractor when he just used regular inlet fitting.

    I guess my question is if the fittings with rubber nozzles were 'special'? I can only seem to find the 1" variety on line. Would installing these get all six of my jets back again, or is it possible I have deeper issues?

    Thanks!
    15K Attached Spa, Gunite, Quartz finish, 60 Sq.ft. De filter, Solar, Propane Heater, 1-1/2 Hp Pump

  2. Back To Top    #2

    TFP Guide

    In the Industry

    Join Date
    Apr 2015
    Location
    tucson, arizona
    Posts
    1,314

    Re: Spa Jet Problems after Refinish

    More than likely they might've gotten some plaster or other material in the jets. The nozzles did originally come with the SP 1430 jet but not entirely sure they enhance the performance

  3. Back To Top    #3

    Join Date
    Apr 2017
    Location
    Orlando
    Posts
    3

    Re: Spa Jet Problems after Refinish

    Checked the inlets for debris and found none. I did notice they seemed to be careful about taping off/covering the returns when they were applying finish
    15K Attached Spa, Gunite, Quartz finish, 60 Sq.ft. De filter, Solar, Propane Heater, 1-1/2 Hp Pump

  4. Back To Top    #4

    TFP Guide

    In the Industry

    Join Date
    Apr 2015
    Location
    tucson, arizona
    Posts
    1,314

    Re: Spa Jet Problems after Refinish

    Can you drain spa below the jets and then turn them on,checking each jets velocity. If they all work about the same fill spa and try again

  5. Back To Top    #5

    Join Date
    Apr 2017
    Location
    Orlando
    Posts
    3

    Re: Spa Jet Problems after Refinish

    Yes...I have done that several times. Both when I noticed the problem than again when I drained the spa to replace fittings with the 3/4" ones versus the 1" ones the contractor installed. With spa empty and/or below jet level, water comes blasting out of jets 1,3,4, and 6...but little to nothing out of jets 2 and 5.
    15K Attached Spa, Gunite, Quartz finish, 60 Sq.ft. De filter, Solar, Propane Heater, 1-1/2 Hp Pump

  6. Back To Top    #6

    TFP Guide

    In the Industry

    Join Date
    Apr 2015
    Location
    tucson, arizona
    Posts
    1,314

    Re: Spa Jet Problems after Refinish

    Can you look up into the jets and see the orfice, check a few that work well and then check the two that don't. Is there any difference in appearance? You may have to remove the two orifices to clear out.

    - - - Updated - - -

    https://www.poolpartsonline.com/wate...rge%2F9630.jpg

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •