Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Pentair autofill problem and question

  1. Back To Top    #1

    Join Date
    Jul 2014
    Location
    round top, texas
    Posts
    8

    Pentair autofill problem and question

    The water supply line broke at the bottom of my autofill. I thought it would be an easy fix as there is a PVC slip fitting that is made with flats so a wrench or socket go on it.To my surprise I found out that the fitting which is threaded into bottom of autofill is glued in at factory. So it looks like I will need to bust concrete and flagstone to put in a new autofill. My question is why does Pentair glue in a threaded fitting? They even give you a spare one with a new autofill unit. Doesn't make sense and looks like whoever is doing the assembly was not trained properly.
    35,000 gal. IG Diamond Brite plaster saltwater pool new as of May 2011. Pentair IC 40 SWG, Pentair Triton II sand filter, Pentair Mastertemp heater, Pentair Whisperflo pump. TFP 100 test kit. Well water.

  2. Back To Top    #2
    Mod Squad Texas Splash's Avatar
    Join Date
    Jun 2014
    Location
    South-Central Texas, Marion/San Antonio
    Posts
    17,323

    Re: Pentair autofill problem and question

    Hello John!
    Doesn't make sense and looks like whoever is doing the assembly was not trained properly.
    I would tend to agree with you as well. While I don't have an autofill, it doesn't seem to make sense. You would think some Teflon tape or plumber's putty might be enough. If someone else with Pentair-specific autofill experience sees your thread, maybe they'll know something we don't. But I agree, it seems odd.

    Have a good TX day.
    Pat (a.k.a. Texas Splash) ~ My Pool: Viking Fiberglass; 17,888 Gal; Waterway Supreme 2-sp/2-hp pump; Hayward Ctg filter; TF-100 w/ Speed Stir
    Vital Links: POOL SCHOOL, RECOMMENDED LEVELS, RECOMMENDED CHEMICALS, Poolmath Calculator, SLAM, Chlorine/CYA CHART.
    If you enjoyed your TFP experience, please consider donating to Support TFP!

  3. Back To Top    #3

    Join Date
    Apr 2017
    Location
    Cathedral City, CA
    Posts
    312

    Re: Pentair autofill problem and question

    Hi Johns6,

    Did you ever get any other info on this? We're preparing to use Pentair's Autofill for our new build, so your post made me aware of a potential problem. If Pentair gives a spare, I question if the PB glued it? Have you checked with Pentair?
    POOL: 9700 gal, 9x30 attached SPA: 7x7. IG, Aqua Cool Pebble. EQUIP: Pentair Easytouch 8SC, IC40 SWG - Screenlogic (522104) w/wireless, Clean and Clear Plus 320 SF (60340), 3 HP VSP (11055) & 1.5HP Whisperflo Pumps (011773), 400K NG Heater (460736), 12 Venturi spa jets, 3 Magicstream Deck Jets II (580003), Aquastar Autofill w/anti-syphon valve, Waterway skimmer. Fill date 04/03/18. TF-100 Test Kit, SpeedStir.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •