Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 5 of 5

Thread: Need help with Hayward multivalve leak

  1. Back To Top    #1

    Join Date
    Aug 2010
    Location
    Lake Jackson, TX
    Posts
    130

    Need help with Hayward multivalve leak

    Hi all,

    Hoping someone can help me figure out why my Hayward 710xr50 is spouting water from the center post. I made the mistake of doing maintenance because the handle was a bit stiff. Upon reassembly the center leaked very badly. I chose to do a full overhaul. I bought the kit from leslies, ouch, and installed. It's leaking just as bad. I think I may have reasswembled wrong but I haven't been able to find a good set of instructions or a schematic to verify.

    Thanks
    25000 gal IG gunite plaster. Built in spa, built 1984.
    48 SF Hayward DE-4800 filter
    1 hp Hayward super pump
    3/4 hp Polaris PB-4 booster pump, Polaris 380
    Taylor K-2006 test kit

  2. Back To Top    #2
    Mod Squad YippeeSkippy's Avatar
    Join Date
    Jan 2012
    Location
    'burbs of Augusta, Georgia
    Posts
    8,550

    Re: Need help with Hayward multivalve leak

    Hey there Dickey, I believe most multiport valves are somewhat stiff when turning.

    Have you looked at Youtube for videos, I believe they have some on replacing the gaskets and such.... may we helpful to check it out.

    Good luck, I wish I had more useful information for you.

    Yip
    Maddie :) 12K Fiberglass IG, Infinity 4000 automatic cover, SWCG, Hayward Sand Filter, Hayward 1.5 Pump, Doheny Discovery Robot, Savi Melody LED pool lights, outdoor speakers and other assorted doo-dads. Sundance Altamar Hot Tub.
    Skippy's Pool Cooler --> Skippy's New Fountain Our Build --> Our Pool Solved Our Sloping Yard

  3. Back To Top    #3
    Richard320's Avatar
    Join Date
    Jan 2010
    Location
    San Dimas, CA (LA County)
    Posts
    20,296

    Re: Need help with Hayward multivalve leak

    You either buggered-up the shaft seal on reassembly or the shaft itself is scored. There's a good exploded view here http://www.discountpoolzone.com/pump...0710parts.html
    16K freeform gunite with spa; Pentair 4000 DE filter; Century Whisperflow 1 HP; Pentair Minimax heater.
    Troublefree does not mean Maintenancefree. It's like brushing your teeth: You can spend a couple minutes a day and pennies a week or go to the dentist once a year and spend several thousand dollars.
    A pool is like a pet - you have to feed it every day, even the days you don't want to play with it!

  4. Back To Top    #4

    Join Date
    Aug 2010
    Location
    Lake Jackson, TX
    Posts
    130

    Re: Need help with Hayward multivalve leak

    I did try you tube but didn't find anything specific.

    - - - Updated - - -

    Quote Originally Posted by Richard320 View Post
    You either buggered-up the shaft seal on reassembly or the shaft itself is scored. There's a good exploded view here http://www.discountpoolzone.com/pump...0710parts.html
    Thanks for the info, I'll have to pull it apart again and try and see what I did.
    25000 gal IG gunite plaster. Built in spa, built 1984.
    48 SF Hayward DE-4800 filter
    1 hp Hayward super pump
    3/4 hp Polaris PB-4 booster pump, Polaris 380
    Taylor K-2006 test kit

  5. Back To Top    #5

    Join Date
    Aug 2010
    Location
    Lake Jackson, TX
    Posts
    130

    Re: Need help with Hayward multivalve leak

    Aha! broken o-ring. Panic over please return to normal life. Thank you.
    25000 gal IG gunite plaster. Built in spa, built 1984.
    48 SF Hayward DE-4800 filter
    1 hp Hayward super pump
    3/4 hp Polaris PB-4 booster pump, Polaris 380
    Taylor K-2006 test kit

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •