Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 3 of 3

Thread: Help!

  1. Back To Top    #1

    Join Date
    Apr 2009
    Location
    Louisiana
    Posts
    64

    Help!

    Trying to vacuum - took the lid off the leaf basket & put it back on crooked I assume! How can I get it off - it won't budge


    19,000 IG Pacific Blue plaster,raised spa with spillover,rock waterfall, Jandy 2.5 HP pump,Pentair sand filter,Paramount in floor cleaning system, Jandy Aquapure SWG, Aqualink remote

  2. Back To Top    #2
    Mod Squad Texas Splash's Avatar
    Join Date
    Jun 2014
    Location
    South-Central Texas, Marion/San Antonio
    Posts
    17,340

    Re: Help!

    Those plastic poolside skimmer lids can seem to just glue themselves on sometimes. Try moistening the lid edges with some water for a bit while tapping gently. A rubber mallet may help. If your lid is like mine, it may have a couple holes on top, so perhaps insert the handle of another tool in it and tap it with the mallet (sideways) to try and help turn it. If it still won't budge, as a last resort, try just a little (very little) WD-40 or vegetable oil around the edge of the lid. Again, very little as we don't want a bunch of run-off going into the water. If you end-up getting a sledgehammer, make sure to post a video for us.
    Pat (a.k.a. Texas Splash) ~ My Pool: Viking Fiberglass; 17,888 Gal; Waterway Supreme 2-sp/2-hp pump; Hayward Ctg filter; TF-100 w/ Speed Stir
    Vital Links: POOL SCHOOL, RECOMMENDED LEVELS, RECOMMENDED CHEMICALS, Poolmath Calculator, SLAM, Chlorine/CYA CHART.
    If you enjoyed your TFP experience, please consider donating to Support TFP!

  3. Back To Top    #3

    Join Date
    Apr 2009
    Location
    Louisiana
    Posts
    64

    Re: Help!

    Thanks - I finally got it off with the help of a rubber mallet. Looks like I may have a suction side leak. Basket won't fill with water - tried to prime by adding a bucket of water. I heard a sputtering noise & saw a small drip on the pipe. Sigh. One step forward - five steps back. I was trying to vacuum during my slam - I just left the pump off. So now I'll have to figure out how to fix this.
    19,000 IG Pacific Blue plaster,raised spa with spillover,rock waterfall, Jandy 2.5 HP pump,Pentair sand filter,Paramount in floor cleaning system, Jandy Aquapure SWG, Aqualink remote

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •