Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 2 of 2

Thread: Pentair EasyTouch "No Comm" problem

  1. Back To Top    #1

    Pentair EasyTouch "No Comm" problem

    Hey guys,

    I came back from a weekend away and found that our Pentair EasyTouch remote can no longer connect to the control panel. I have done a lot of research and tried a bunch of things but so far no joy. I talked to a tech at Pentair in California today and I might as well have just called down to the Walmart. Needless to say the frustration is mounting.

    Things I have tried:
    - Tried to do the readdress dance many times but the remote just keeps on searching until it turns off.
    - Reset the power to the panel and tried the readdress dance.
    - Did the "Reset system" via the diagnostics page on both the controller and the panel.
    - Verified that I am getting 16.9vDC across the black and red leads on the antenna.
    - Verified that the power light on the antenna is solid red and that the other two lights go on and off and different intervals.
    - Placed a screen behind the antenna in an attempt to block any potential interference.
    - Reset the EEPROM on the remote.
    - Change the batteries on the remote.
    - Verified that all wires from the antenna are connected and secure.

    Does anyone have any suggestions for any further tests that I can try before I start giving more money to Pentair?

    Also...how do I determine if the problem is with the remote, the antenna, or the board in the control unit?

    And finally...are there any 3rd party options that I could go with for controlling the Pentair system?

    Thanks!

    Scott
    20k gallon AG pebble pool in Austin, Texas. All Pentair equipment (DE, IC40 SWCG, heatpump, variable speed pump with aux pump for the cleaner). Built in 4/2013.

  2. Back To Top    #2
    Mod Squad Jimrahbe's Avatar
    Join Date
    Jul 2014
    Location
    Bedford, TX
    Posts
    9,248

    Re: Pentair EasyTouch "No Comm" problem

    Scott,

    The only two options for remotely controlling an EasyTouch is the remote you have now and ScreenLogic2.

    I have never had the remote, so I'm not much of a resource for how to get it to reconnect...

    I do have ScreenLogic 2 and love it. Costs about $375 at SunPlay. Lets you control your pool from your PC, Tablet, or Phone.

    You can program via your PC about 10 x easier than using the little 3" LCD.. The phone works pretty well for viewing and turning things on/off but not so well for programming.

    Sorry to hear about your remote problems.. Maybe some of our Pentair remote users will chime in..

    Jim R.
    Finished in 2015 - 17K Gal, IG, 20' x 25' Almost Rectangular Pool, Pebble finish, three rockport water falls. Pentair Equipment: EasyTouch 4, IC40 SWG, 3 HP VS Pump, CCP520 Cartridge Filter.
    TF100 with SpeedStir and SampleSizer, ColorQ Pro 7, Dolphin Premier Robot Cleaner, added Screen Logic 2, added small 3 person Caldera Spa.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •