Become a TFP Supporter Pool Math Forum Rules Pool School
Results 1 to 14 of 14

Thread: Is my SWG going bad?

  1. Back To Top    #1

    Join Date
    Jun 2016
    Location
    San Diego, CA
    Posts
    31

    Is my SWG going bad?

    Hello all,
    I have a Pentair salt water chlorine generator IC40, and sometimes the cell light is on and sometimes it's off.

    Is that normal?








    Salt water 28,000 Gal Pool with 1,200 Gal Spa
    Satin Matrix Pebble surface
    Pentair Intellichlor Salt Chlorinating system, Pentair Intellifo Variable Speed Pump
    Pentair 400,000 BTU heater, Dolphin DX5S Robotic pool cleaner
    750 sq foot Solar Pool Heating, Rock Grotto with waterfall

  2. Back To Top    #2
    Mod Squad Jimrahbe's Avatar
    Join Date
    Jul 2014
    Location
    Bedford, TX
    Posts
    9,249

    Re: Is my SWG going bad?

    D,

    Yes completely normal.. Your cell is set to 60% so it will be on only 60% of the time. That is how they work.

    The SWCG does not change the amount of chlorine it generates, it just changes the amount of time it generates chlorine.

    Thanks for posting,

    Jim R.
    Finished in 2015 - 17K Gal, IG, 20' x 25' Almost Rectangular Pool, Pebble finish, three rockport water falls. Pentair Equipment: EasyTouch 4, IC40 SWG, 3 HP VS Pump, CCP520 Cartridge Filter.
    TF100 with SpeedStir and SampleSizer, ColorQ Pro 7, Dolphin Premier Robot Cleaner, added Screen Logic 2, added small 3 person Caldera Spa.

  3. Back To Top    #3

    Join Date
    Jun 2016
    Location
    San Diego, CA
    Posts
    31

    Re: Is my SWG going bad?

    Quote Originally Posted by Jimrahbe View Post
    D,

    Yes completely normal.. Your cell is set to 60% so it will be on only 60% of the time. That is how they work.

    The SWCG does not change the amount of chlorine it generates, it just changes the amount of time it generates chlorine.

    Thanks for posting,

    Jim R.
    Thank you so much Jim for clarifying that.



    Salt water 28,000 Gal Pool with 1,200 Gal Spa
    Satin Matrix Pebble surface
    Pentair Intellichlor Salt Chlorinating system, Pentair Intellifo Variable Speed Pump
    Pentair 400,000 BTU heater, Dolphin DX5S Robotic pool cleaner
    750 sq foot Solar Pool Heating, Rock Grotto with waterfall

  4. Back To Top    #4
    PoolingAround's Avatar
    Join Date
    May 2016
    Location
    Katy, Texas
    Posts
    214

    Re: Is my SWG going bad?

    Not to hijack the thread but my control unit for the SWG keeps going to checking cell. This suspends the SWG unit and my on demand acid. When I power off everything it comes back normal but hours later back to checking cell status. Any thoughts?
    18k gallon, 20x32, salt IC20, gunite with quartz finish, raised spa with overflow, flagstone coping, moss rock waterfall, Pentair Intelliflo variable speed pump, Pentair Racer, Pentair pool pump, cartridge filter, heater, etc., acid dispenser.
    TF-100 kit for sparkling clean water.

  5. Back To Top    #5

    Join Date
    Jun 2016
    Location
    San Diego, CA
    Posts
    31

    Re: Is my SWG going bad?

    When was the last time you cleaned the cell?
    Maybe there are calcium deposits on it.



    Salt water 28,000 Gal Pool with 1,200 Gal Spa
    Satin Matrix Pebble surface
    Pentair Intellichlor Salt Chlorinating system, Pentair Intellifo Variable Speed Pump
    Pentair 400,000 BTU heater, Dolphin DX5S Robotic pool cleaner
    750 sq foot Solar Pool Heating, Rock Grotto with waterfall

  6. Back To Top    #6
    PoolingAround's Avatar
    Join Date
    May 2016
    Location
    Katy, Texas
    Posts
    214

    Re: Is my SWG going bad?

    Quote Originally Posted by drimran View Post
    When was the last time you cleaned the cell?
    Maybe there are calcium deposits on it.



    Sent from my iPhone using Tapatalk

    Cleaned the cell 2 months ago. No calcium present.
    18k gallon, 20x32, salt IC20, gunite with quartz finish, raised spa with overflow, flagstone coping, moss rock waterfall, Pentair Intelliflo variable speed pump, Pentair Racer, Pentair pool pump, cartridge filter, heater, etc., acid dispenser.
    TF-100 kit for sparkling clean water.

  7. Back To Top    #7
    PoolingAround's Avatar
    Join Date
    May 2016
    Location
    Katy, Texas
    Posts
    214

    Re: Is my SWG going bad?

    Hi All,

    My SWG went from being stuck on checking cell to now saying its low on salt (when I know its not). Hasn't produced chlorine in days. This is leading me to believe this thing is faulty. Anyone else think the same?
    18k gallon, 20x32, salt IC20, gunite with quartz finish, raised spa with overflow, flagstone coping, moss rock waterfall, Pentair Intelliflo variable speed pump, Pentair Racer, Pentair pool pump, cartridge filter, heater, etc., acid dispenser.
    TF-100 kit for sparkling clean water.

  8. Back To Top    #8
    Mod Squad pooldv's Avatar
    Join Date
    Aug 2012
    Location
    DFW, TX
    Posts
    24,974

    Re: Is my SWG going bad?

    What is the actual salt level? And what test are you using?
    TFP Moderator
    If TFP helped you or saved you money - Become a TFP Supporter! <--Click here
    2012 build and pics, 20k gal gunite, black onyx pebblesheen, OK flagstone, IntellifoVS, cart filter w/Pleatco, IC40 SWG, Solartouch, 5 12'x4' solar panels, HP50HA heat pump, 8mil solar cover, borates, TF-100 test kit, SONOS, Doheny's Discovery Robot, hot tub on bleach

  9. Back To Top    #9
    PoolingAround's Avatar
    Join Date
    May 2016
    Location
    Katy, Texas
    Posts
    214

    Re: Is my SWG going bad?

    Quote Originally Posted by pooldv View Post
    What is the actual salt level? And what test are you using?
    Salt level is 3400 -3500 (salt strips). Salt cell said 3500 a week ago, 3700 2 days ago, now says its low. Thing is acting wonky.
    18k gallon, 20x32, salt IC20, gunite with quartz finish, raised spa with overflow, flagstone coping, moss rock waterfall, Pentair Intelliflo variable speed pump, Pentair Racer, Pentair pool pump, cartridge filter, heater, etc., acid dispenser.
    TF-100 kit for sparkling clean water.

  10. Back To Top    #10
    Mod Squad pooldv's Avatar
    Join Date
    Aug 2012
    Location
    DFW, TX
    Posts
    24,974

    Re: Is my SWG going bad?

    That should be plenty of salt. How old is the cell?
    TFP Moderator
    If TFP helped you or saved you money - Become a TFP Supporter! <--Click here
    2012 build and pics, 20k gal gunite, black onyx pebblesheen, OK flagstone, IntellifoVS, cart filter w/Pleatco, IC40 SWG, Solartouch, 5 12'x4' solar panels, HP50HA heat pump, 8mil solar cover, borates, TF-100 test kit, SONOS, Doheny's Discovery Robot, hot tub on bleach

  11. Back To Top    #11
    PoolingAround's Avatar
    Join Date
    May 2016
    Location
    Katy, Texas
    Posts
    214

    Re: Is my SWG going bad?

    Quote Originally Posted by pooldv View Post
    That should be plenty of salt. How old is the cell?
    9 months old.
    18k gallon, 20x32, salt IC20, gunite with quartz finish, raised spa with overflow, flagstone coping, moss rock waterfall, Pentair Intelliflo variable speed pump, Pentair Racer, Pentair pool pump, cartridge filter, heater, etc., acid dispenser.
    TF-100 kit for sparkling clean water.

  12. Back To Top    #12
    Mod Squad pooldv's Avatar
    Join Date
    Aug 2012
    Location
    DFW, TX
    Posts
    24,974

    Re: Is my SWG going bad?

    Oh, heck, call your PB and ask them to warranty it.
    TFP Moderator
    If TFP helped you or saved you money - Become a TFP Supporter! <--Click here
    2012 build and pics, 20k gal gunite, black onyx pebblesheen, OK flagstone, IntellifoVS, cart filter w/Pleatco, IC40 SWG, Solartouch, 5 12'x4' solar panels, HP50HA heat pump, 8mil solar cover, borates, TF-100 test kit, SONOS, Doheny's Discovery Robot, hot tub on bleach

  13. Back To Top    #13

    Join Date
    Jul 2016
    Location
    Central pa
    Posts
    6

    Re: Is my SWG going bad?

    Im not sure if you are dealing with the same "issues" I thought I had with my IC40, but it was reading levels all over the place until my pool water reached 61 degrees. my unit is only 9 months old as well and I thought it went bad already. although the manual states 55 degrees (or something close to that) after doing extensive research and talking with people, it seems the unit doesn't want to work properly until the water temps are above 60. I guess the manufacture also calibrates the until to read accurate salt levels at 77 degrees as well, so you either have to compensate for the values given at the current temps or buy a drop test kit to measure accurate readings of salt levels.
    16x32 IG SWG 18,000 gallons
    Vinyl Liner
    Pentair intelliflo variable speed 3HP
    Pentair Water IntelliChlor
    Pentair Sand Dollar sand filter SD-80

  14. Back To Top    #14

    In the Industry

    Join Date
    Apr 2015
    Location
    Waikoloa Hawaii
    Posts
    13

    Is my SWG going bad?

    Pentair had an issue with a bunch of bad flow/temp sensors a while back. If your water temp is high enough, I'd say get them to warranty replacement. The sensor is easily replaceable if you can't get it covered under the warranty



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •